Not booting after initial setup

Hi,
I set up the Jetson Nano according to the setup guide by flashing a micro SD card. I then plugged in HDMI, USB keyboard and mouse, and powered it through the USB port. The module powered up and let me do the initial setup for username and passwords and then I plugged in the ethernet cable. It then proceeded to install a few packages and then shut down and never powered back up again. The green LED near the micro USB is on when I power it with either the micro USB or barrel jack (5V 4A) but there is no feedback from the monitor, not even the splash screen.

I then tried booting in recovery and tried flashing jetpack with sdkmanager. It flashes the image (installation goes till 50%) and then doesn’t proceed further. Any advice on what might be going wrong?

nredla,

Could you share the log of your flash error?

I was just about to post an update. Everything is alright with the Nano. Just had to try different cables, the display was broken too.

Sorry about that, how do I delete this topic?

It is fine. Just keep this thread here.

Hello,

I am having a very similar issue. I setup my Nano without any issues, but after powering it off, I have been having some issues.

Specifically, I see that the green LED is on, indicating that the device is powered, but nothing is shown on my display and the Nano is not able to power any peripheral devices. nredla, which “different cables” did you try to fix the issue?

Note: This is the power supply that I’m using
https://www.amazon.com/gp/product/B0117O020U/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1

I tried the micro USB 5V 2.5A power supply you usually get with a Canakit : https://www.amazon.com/dp/B00MARDJZ4

And also the power supply I had for an Up Board: https://up-shop.org/up-peripherals/65-dc-power-adapter-for-up-board-eu-plug.html

Worked pretty well with both supplies.

My display’s HDMI port stopped working after the initial setup. I dont think it was the Nano. Worked fine on another monitor.

Hi,

Just receive Nano one hour ago. Setup done and now green led after booting is ON and then OFF after a minute.
Power supply is 2A. I try to remove all cable, HDMI, USB and only keep power supply thru miniUSB.

Unfortunately, got same issue, LED turn off after few second.

Could you help please?

Hi thiery,

As our suggestions, you’ll need to power the developer kit with a good quality power supply that can deliver 5V⎓2A at the developer kit’s Micro-USB port. Not every power supply rated at “5V⎓2A” will actually do this.
Please try with another power source to see if can work well.

See also: https://devtalk.nvidia.com/default/topic/1048640/jetson-nano/power-supply-considerations-for-jetson-nano-developer-kit/

Thanks

Hi Kay,

Thanks for your answer.

Since yesterday, I ordered and install new micro SD card which is more faster than older and now all working fine,

Thanks again

Hi thiery,

Could you share the part number of that sdcard which is not compatible?