Nvidia jetson nano not booting

Whenever I switch on the board from battery or socker, the green LED is turned ON and automatically it gets shutdown in a fraction of seconds.

I connected the board to a HDMI display; still we are facing the issue. We are working on a critical robot project and currently got stuck in this hassle. Please let me know what to be done further. I tried flashing with a SD card as well. Still not working!!! Help us.

Is the power supply dedicated to the Nano, and nothing else draws power from this same supply? Often it is a case of the power not being sufficiently stable right at the start of power up. Having power on average tends to not work well for computers.

Also, peripherals which are powered by the Nano itself (USB devices for the most part) can draw too much power. You can safely ignore power draw from a mouse or keyboard, but some devices, such as cameras, might draw too much power for USB delivery. In that case you’d need to switch to the DC barrel jack for power.