Jetson Nano not displaying

I’m having an issue where my Jetson Nano is not displaying. The power light turns on and is green, and I have swapped out the power supply and displays several times. I have also used both HDMI and DisplayPort to test the system out. As a precautionary measure I have also redownloaded the .img file and reimaged my SD card on a different system. I have also attempted a boot without the SD card, and I still cant get anything to display. The SD card works on my openSUSE setup, so I think the image went through properly.

I made an attempt to reseat the board and that didn’t work either. On a side note, whenever I removed the module, it looked like a piece of plastic was in-between the contacts and the module. More cellophane like than hard plastic.

I am also using a 128 GB Samsung EVO Select microSD if that makes a difference.

Thanks!

Edit 1: I have contacted support via live chat and they have told me to post here. This is also straight out of the box.

Hi jpegthedev,

Not sure your power supply could offer 5V-2.5A to Nano, if you confirmed that’d not an issue, then it seems to be a board issue, please go for RMA:
https://developer.nvidia.com/embedded/faq#rma-process

Thanks

The Nano does not display on some HDMI and DisplayPort monitors. My suggestion is to find a 1080P TV set and connect that via an HDMI cable, at least till the box is up and running.

Hi jpegthedev,

Have you submitted the unit for RMA? Would you please add the RMA No. here for our team to track this issue?
If not yet? Could you add kernel and xorg display logs here so can see if could identify any issues training with the display?

Thanks

I am using raspberry pi USB power supply of 5V-2.5 amp power supply for power up Jetson Nano.
I use the same power supply with raspberry pi and same TV to work it.But with same Tv the nano is not displaying anything.The LED is continously on. So does that mean the NANO is on but not displaying anything.

5V-2.5A raspberry pi power supply is not enough??
I am using this TV :telefunken led tv d32f286x3c which works with raspberry pi not with NANO.

Can anybody help me here.

Do you have a UART-USB converter? If so, you can monitor the device during boot – to see if it’s a monitor issue.

Do you have an oscilloscope? If so, you can monitor the rail voltage during boot up – it should be rock steady at 5 V – if it drops, you’ll know your power supply is insufficient.

if you are not getting any visual, but for the green led - you might have flashed the sdcard erroneously.
Make sure you have written the image to the entire space like mmcblk1 rather than to a partition of it like mmcblk1p1

Sorry for the delay, but I did RMA it and it did solve the issue. RMA: 65054339101.

That partially worked. It did display on HDMI but never fully booted. Guessing that it was a bad chip.

The raspberry pi power adapter should work out fine. Give it a shot on another display and as Andrey1984 suggested, verify that you have flashed the drive properly. If that does not work, go ahead and create an RMA as suggested above, it worked for me.

Hi jpegthedev,

Sorry for the bad chip. Could you confirm if the RMA number is “65054339101”?

Yep, that’s what my RMA email says.

Face issue like, LED is on,the LEDs of keyboard and mouse also on,but no display.Just connect the HDMI LCD with pure HDMI cabel(no connectors) and now its wokring fine.

hello, I have a problem displaying the Jetson Nano display output to the monitor, I initially tried to use a monitor with the same VGA display input conversion to HDMI, at first the boot went smoothly without any problems until the NVIDIA logo appeared and I was able to log in to user registration, but when registration is complete and try to enter the desktop page my computer suddenly turns off, where the green light on the computer also dies, and on the monitor screen can not display anything there is only the writing no signal, I try to turn on my computer but unsuccessfully, I tried to reinstall my sd card again and tried the manual installation step but it still didn’t work. Do friends have a solution to my problem? I beg for your help, because this concerns my university graduation. Thank you

  1. Please try to see if you could see the log fomr serial console. If it does not have log after power on, then your Nano is probably dead and need a RMA process.

https://www.jetsonhacks.com/2019/04/19/jetson-nano-serial-console/

  1. Please find a monitor with a native HDMI port. Actually, jetson nano has a bad compatibility with adapters like VGA->HDMI.