Nvidia jetson nano setup screen not coming

I received my Nvidia jetson nano device today. I downloaded the image from the Nvidia website and wrote it to the 128gb sd card in accordance with the instructions.
Then I supplied 5V 2A power with USB cable. Green light came on from the device, but the screen did not show up. The logo and the setup screen did not appear. (I get an image with HDMI) Can you help? Where did I go wrong?

What do you mean by the above? Are you using two monitors and the HDMI one works? If another monitor is also involved, then describe all cabling and adapters as well.

Are you able to ssh into the Nano? I assume probably not since you wouldn’t have finished the first boot setup without the monitor/keyboard.

There is only one monitor connected with HDMI, the equipment connected to the device is mouse, keyboard and power connection. I can’t get any images, setup etc. does not start.

Would you be able to show a serial console boot log? See:
https://www.jetsonhacks.com/2019/04/19/jetson-nano-serial-console/

Also, if you have access to a wired router where you can see IP addresses assigned to devices, perhaps you could connect the wired ethernet and try to ping that address. Without first boot account setup you wouldn’t be logged in, but you would still know if boot was otherwise valid.

I rewrote the image to the sd card. And I gave power to the device, the image came on the screen, the text came out, but the image came and went to the monitor. I was able to come to the main setup screen, then the image is completely gone. The monitor does not have any problems, it displays images clearly on my personal computers. Could it be because of the USB supply (5V 2A)? I just ordered a recommended adapter (5V 4A). If problems persist, I will have to return the product to the seller.

Power supplies have often shown up as a problem, but when this is the issue, the system typically turns off and does not simply continue running in some non-working state. The system continuing to run, but not displaying setup, is most likely not related to the power supply. Anything shutting down is likely power supply related.

Regarding more detail on power supplies, there are many “good” power supplies which fail just because they need a very tight voltage regulation at the moment of starting. Sometimes when the Nano does something which consumes more power, then a marginal supply will also end up with the Jetson shutting down. Running with errors is generally not a power supply issues, shutting down is.

Do the LEDs turn off when the text goes away?

There is a similar issue with monitors. The modern mechanism of finding a monitor’s specifications in order for the video driver to work is to query the monitor for its EDID data. This is done with an i2c protocol over the “DDC” wire of HDMI. If anything interferes with this, e.g., if the monitor is using an adapter and does not provide EDID due to being older technology, then automatic configuration will fail even if the monitor is otherwise functioning correctly (the video driver won’t be able to set up for a monitor it does not know the specs of).

There are also several video mode restrictions which do not exist on PCs. A number of modes, even if EDID provides them, will be rejected. No interlaced mode is accepted, extension modes are not accepted, and some modes may just be oddball and not on the list of the “standard” modes. Custom modes tend to be rejected.

Even a monitor without the correct EDID may momentarily provide output since the video driver can revert to a default mode. The monitor would be 100% functional, but still fail other than during brief moments as modes switch.

Aside from a Nano which completely shuts down I would say most likely there is just an issue with setting up the first login. Whether or not that issue is from a monitor which cannot be configured I do not know (this is why the serial console log is good…plus first boot login can be completed via serial console). Serial console is very important to know what is happening.

I have received the recommended adapter and the result has not changed, no image appears. I tried from two different HDMI monitors, the result is still the same. Nothing appears on the screen. I will take a look at it for three more days and return it if the result does not change.

I would suggest to dump the serial console log directly.

https://elinux.org/Jetson/General_debug

have you solved it? or return it?
my jetson nano worked well before, but i come across the same problem just today.
the green light is on (no matter USB or 5V4A), but nothing appears on the screen.
waiting for a solution~~~

See the link @WayneWWW gave for serial console:
https://elinux.org/Jetson/General_debug
…you’ll need to try to get a serial console boot log to know what is going wrong (serial console works even when networking and graphics fail, and also works in earlier stages prior to Linux itself ever starting).

After reading this tutorial(https://www.jetsonhacks.com/2019/04/19/jetson-nano-serial-console/), i have tried the serial debug console. However, nothing appeared

. I have upload some pictures to ensure the operation is right.

You will need to use the logging feature from the serial console program to get a text-based log instead of images. I tend to use gtkterm ("sudo apt-get install gtkterm"), and assuming from your dmesg above that this is “/dev/ttyS0” on the host PC, then you would be able to run like this (also use “sudo” if your login account is not a member of group “dialout”):
gtkterm -b 8 -t 1 -s 115200 -p /dev/ttyS0
(then experiment a bit to see if it works during boot, and clear the screen with Jetson off, turn on logging, then boot the Jetson)

Since all of the wires are the same color I don’t know if it is correctly connected, but you want the TX of one going to the RX of the other, plus ground to ground.

Thank you, i have tried ‘gtkterm’, which is more user-friendly. However, only a few letters—“0: FF 80 00” appeared on the screen when i turned on. And when i shut down and turned on again, letters became fewer—“0: 00”. Very confused~i bought the nano(B01) four months ago, and it worked well, but last Saturday i turned on as usual and it failed.

That is odd, and could be actual hardware failure. Are you using a dev kit? Or are you using a third party carrier board? A third party carrier board would require different firmware and might look like a hardware failure even though it isn’t. Mixing an earlier revision a02 module/carrier board with a b01 revision module/carrier board would also cause issues.