Jetson Nano is not booting screen first time

My Jetson Nano is not showing the booting screen the first time…

I can see the green light ON, when I power Jetson nano. However, it is not showing the booting screen (NVIDIA logo) on monitor.

Could you please suggest how can I resolve this issue?

VGA is not supported. Automatic video configuration requires the DDC wire which VGA does not have. Your system is probably fully up and running, but video would not be able to configure.

1 Like

thank you so much @linuxdev for the support.

Just to sharing how I have connected - HDMI port of Jetson Nano to the monitor

Step 1: I have been using the “HDMI output port” of NVIDIA Jetson Nano.

Step2: I have plugged “HDMI to VGA converter” (like this :

Step 3: Then, I have used “male VGA connector” to plug Step 2 converter (like this:

Step 4: I have plugged the “male VGA” (of Step 3) to my monitor.

Kindly let me know if I am doing any mistakes. Please suggest the solution to resolve this issue

Does this mean that I should use only HDMI cable like this ( to connect the Jetson Nano to the monitor for display screen. I can not use the monitor which has VGA input?

Kindly advise @linuxdev

I also have the same problem and same configuration ,except I am using 64GB and 32GB

1 Like

This won’t work. The VGA will not pass through the configuration information. Think of the DDC wire as providing the same information which an old VGA “driver disk” would provide, but automatically. This is what makes HDMI plug-n-play when VGA does not. There might be some old VGA monitors with more than one port where there is an attempt to put the DDC wire through, but the protocol will be wrong and would not work even if you have this.

The drivers no longer accept custom modes, and an external database file or setting manually is not accepted, so you can only use the plug-n-play method. Maybe you would get lucky and some fallback default mode would work, but it seems not in this case.

Any cable which is purely HDMI will work. This means your monitor must have an actual HDMI port. DisplayPort also works, but you might as well stick to HDMI. Some digital “DVI-D” monitors can work with an adapter, but the digital DVI passes through the right data (the “EDID” data).

1 Like

Thank you so much @linuxdev for the answer!

I am just wondering – Is this NVIDIA Jetson Nano specific problem?
I am asking because HDMI to VGA converter approach works perfectly on Raspberry PI 3.

Please let me know what you think

All Jetsons will behave this way. Mostly this is due to the NVIDIA integrated GPU driver restricting configuration to EDID. The discrete GPU drivers do not have this restriction, and of course the open source Nouveau driver doesn’t even use the GPU (and cannot provide CUDA or other hardware acceleration). All Jetsons have the iGPU driver instead of the dGPU driver.

1 Like

@linuxdev: thank you so much for the prompt help!!!


I have the same problem except that I am using a 64 GB microSD. I tried using both HDMI powered and HDMI to VGA convertor with its own power supply. Neither worked. Then I tried headless boot with USB cable plugged into Win 10 machine. That didn’t work either. I am going to try plugging into HDMI input of my TV in morning to see if that works.

1 Like

@vkapoor: HDMI cable works for me.

Please do not use “HDMI to VGA converter” between your Jetson Nano and Monitor.

My problem was that the microSD card was didn’t have the nano image as I accidentally imaged another 64 GB internal drive instead. After plugging the card with an image I had no issues. It works fine with both my HDMI to VGA adapters.

The VGA adapter will result in a default mode being used, rather than configuring for the monitor. If it works, then it is a case of being lucky, but in engineering, I won’t complain about being lucky. :P

Yes, it used a resolution like 1280x780 rather than 1400x900 which the monitor also supports and at first I couldn’t figure out how to force it to use 1400x900. But after I added a screen resolution as described in Jetson TX1 Desktop Sharing Resolution Problem Without Real Monitor it worked fine. I am using VNC now which is more convenient but somewhat slow compared to using a KVM switch. But just wanted to note that HDMI to VGA connectors do work. There is no fundamental limitation.

1 Like