Jetson Nano first Setup and Boot

i bought the Jetson Nano Kit and am trying to get it up and running. Unfortunately, the software setup does not work. When I bought it, the SD card was flashed and a power supply was included.

When starting, only a black background with the NVIDIA logo appears.

Since I am new to the matter and do not have much knowledge I am happy about any help.

How is the monitor connected? Is it purely HDMI, without any adapters?

If there is a chance you can obtain a serial console boot log, then this would be very useful. Quite often everything boots and runs fine, but you just can’t see video. Serial console has almost no dependencies and shows logs even from bootloader stages. Here is serial console information:

You’d need the 3.3V TTL level serial console cable, which are generally not too expensive, but with the holidays you might end up requiring more shipping time. An alternative, if the unit really is booted (you’d have to give it a couple of minutes after powering up), you might try the key binding “CTRL-ALT-F3” (if it thinks it is in GUI mode) or “ALT-F3” (if it thinks it is in text mode). This should put you on the third text terminal, which has much simpler video requirements than GUI.

Additionally, if you have wired ethernet, then you can probably find out from your router if an IP address was assigned. If so, then you could at least ping the address to see if it is alive. You wouldn’t be able to log in since first boot account setup is not complete, but you’d at least be able to narrow it down to just being a video issue.

Thanks for the answer.
The monitor is connected through a normal HDMI cable without adapter.
Because of the 3.3V TTL I have looked. Unfortunately, I would receive this much later than planned.
Since the device was not yet connected, it has no IP address (if I understood correctly).

To be more specific:

I purchased a complete Sparkfun kit including Jetson Nano. The SD card is pre-flashed and a powerbank is used as power supply. (I also tried it with a different 5V power supply).

Following Sparkfun’s instructions, all I have to do is insert the pre-flashed SD card and turn on the Nano. The green LED on the Nano board turns on and you can feel that the Nano is getting warm. I use my TV as a screen. I also connect a USB keyboard and USB mouse. When I use my mouse on my laptop, a light on the bottom of the mouse comes on. When my mouse is connected to the Jetson Nano, this light does not come on.

A small display from Sparkfun is connected to the expansion header J41. This should turn on according to the instructions from Sparkfun. However, this small display does not turn on either.
Even after an hour, only the NVIDIA logo appears on the TV (via HDMI) and nothing happens.

If you connect a Micro-USB cable from your Nano’s Micro-USB port to your PC, a bit after it is powered on you should be able to ping from your PC. This is the static IP of your Nano over the Micro-USB. It creates a virtual ethernet connection, and you may also see a virtual drive pop-up on your PC with additional connecting instructions. You should be able to SSH into your Jetson from your PC using this IP as well.

Once in, you could query the display modes being enumerated from your TV’s EDID using xrandr utility or similar. But more likely, is to just try another HDMI display if you have one. If you can’t ever ping, try disconnecting the TV from your Jetson in case that is halting the boot-up for some reason.

Regardless, you should be able to setup the Jetbot’s wifi while SSH’d into the Nano over the Micro-USB connection. You can run a command like this to join the wifi network:

sudo nmcli device wifi connect <SSID> password <your password>

I do not know anything about the Sparkfun carrier board, but it is likely that if this is not a developer kit (and the image does not look like the dev kit carrier board), then Sparkfun would have made some device tree edits. This won’t matter to you if you are not flashing, but when debugging this, keep in mind that you’d need to use the flash software for that particular carrier board.

Normally I would say a TV often fails. You are correct to use purely HDMI, but the Jetson video drivers have a few mode restrictions desktop PC drivers do not have. “Extension” modes are not allowed, and it is possible this would just be an issue of the monitor compatibility and not a software issue (you could try other HDMI monitors if that were the case).

However, what you describe with the NVIDIA logo showing up and not going away says you have an actual boot failure. If boot stops and locks at the NVIDIA logo step, then I doubt serial console will say anything useful (it might, but the logo is from a very very early part of boot).

Although what you describe probably is not caused by the HDMI television I would still suggest finding out if use of a regular computer HDMI monitor changes anything (it might, the odds just are not high, but it simplifies life to try this early on in case an HDMI error is what causes the lockup).

Do you have another monitor you can try? Does Sparkfun provide any kind of downloadable image you could install via Etcher?

1 Like

If it is in fact a boot failure, you can download the SparkFun JetBot image from here and re-flash your SD card with Etcher:

The SparkFun JetBot kit uses an ordinary Jetson Nano Developer Kit, so there isn’t a special device tree or whatnot. However they have installed some additional drivers for their motor controller and mini-OLED in the image, which makes it slightly different than our JetBot image.

I agree though to try a different HDMI display if you have one, alternatively try the Micro-USB and SSH method (with the TV disconnected). Baring that, re-flash the SD card.

1 Like

Thank you for your support. I tried all the suggestions like pinging, different display etc but none worked. In the end I reflashed the SD card and now it works.

Unfortunately the system is very slow and hangs often. Is this normal?

And if I agree to update to a newer Ubuntu verion will the data from Spakfun be lost (driver etc.)?

When you flash all is erased. If it were an eMMC model, then you could clone first to still have access to the content. An SD card rootfs partition can itself be copied to your host PC so this won’t be lost. When you flash though, you’d need to first check with the Sparkfun documents since these will likely tell you where to get that extra content when you flash.

Don’t forget that if this is an SD card model, then you could get a second SD card and flash that, leaving the original untouched.