No graphic output from Jetson Nano after initial setup

Hi,
I’ve recently purchased a Jetson Nano Dev kit, B01 variant.

I completed the set up procedure outlined on the user guide and was able to connect to the device. While completing the initial setup (accept agreement, set up user name and password etc) the display went black.

I’ve tried using more robust power supplies, trying both the USB and the 5 mm barrel jack (with jumper pin enabled), have tried using Display Port output and HDMI to screen (Screen natively accepts HDMI - no adapters used), and have tried reformatting the microSD card and reimaging, using the instructed SD card formatter and Etcher program listed on the user beginner guide.

When plugging in power, the green light is on. When I short the reset pin, I can see the green light turns off, then back on a moment later, but still no output to screen.

I’ve just about run out of troubleshooting ideas that I can think of. My very last idea is to buy another microUSB card and do a fresh install of the OS onto it. After that, I’ll be entirely stumped.

Cheers,
Scott

Hello,

Welcome to the NVIDIA Developer forums! Your topic will be best served in the Jetson category.

I will move this post over for visibility.

Cheers,
Tom

Serial console will tell you whether the device is still alive:

hi, I’ve followed the video up to the console in puTTY - I’m getting error “the last usb device you connected malfunctioned” messages from windows,

No text is visible on the console window.

Powering down the nano triggers the usb unplugged soundbite, similarly, powering up the USB triggers the usb plugged in sound.

Don’t use Windows.
You will still need Linux/Ubuntu in case you need to re-flash it.

is that a literal instruction, or a “it’s better if you not use windows” ? All of the documentation so far have suggested that my PC on windows is ok.

I do want to re-state that at the beginning of this journey, I was able to run and interact with the Nano via the usb mouse keyboard and monitor plugged into its HDMI port

We don’t verify anything on Windows.
Please handle the connection issue yourself.
Or see if re-flashing the SD card works.

My apologies if this sounds a bit silly, but I’m not quite sure what your reply means.

Can you please clarify the connection issue note.
Also, what do you mean regarding not verifying anything on windows?

I have performed a reformat and re-imaging of the SD card using the zip file provided on the “Getting Started with Jetson Nano” instruction page, but that did not resolve the issue. The only other test that I can think of, is to purchase a new SD card and install the image onto it. Following that, I believe the Nano may be faulty.

Cheers,
Scott

We don’t use Windows for getting serial console log.

All of the flashing process has to be done on Linux.

That means something in the bootloader is corrupted, and will not be recovered by flashing only the SD card.
You need to re-flash the entire device with SDK Manager, which requires a Ubuntu PC.

Ok!

So, I’ve installed a VM, ran Ubuntu and tried to get SDK - no joy, VMs are apparently shaky using SDK. No worries.

Create Ubuntu bootable external HDD, and am now currently on my PC on Ubuntu 22.04.
I’ve installed SDK manager and signed in, sweet!
When I select the Jetson Nano, no available SDK versions are selectable. I can see Jetpack 4.6.4 on the list, but apparently that’s only available on Ubuntu 18.04, even though the SDK manager is documented as being compatible with 22.04.

Another thread in here informs me that, while the SDK manager is compatible, for some reason the file that the manager will load onto the Jetson is not compatible… in what world…

So now, I’m off to try to either spoof the version inside the text files of the SDK manager, or find a new ISO of an older version of Ubuntu to re-image the external SSD so I can run the older version of the OS so that the manager will install a file.

If I’ve got this wrong, I’d love to know, but if the above is accurate, this is kind of embarrassing really.

This page clearly tells you that JetPack 4 can only be installed with Ubuntu 16.04/18.04:

very true, there is documentation stating the version of Jetpack that is supported, however I had a hard time finding a reference of newer versions of Jetpack not being compatible with Jetson Nano.

I saw the note taken from the Developer User Guide

• Ubuntu Linux x64 Version 18.04 or 16.04

but I misunderstood that the instruction also directed me that later versions of Jetpack were not compatible. Apart from that note, version numbers are not referenced.

SDK manager has re-imaged the device. There is now output to the display.
Thank you for your time and assistance with this.

1 Like