Jetson Nano Does Not Work Properly

Hello,

my Jetson Nano doesn’t want to turn on anymore! I used it a couple of days, running the examples. Today I turned it on and the screen remained black: nothing has changed since yesterday. Power led remains green, but nothing happens. Some informations:

  • using micro USB power input (5V - 2.25A power supply);
  • tried to change monitor, HDMI cable, mouse, keyboard;
  • reformatted micro sd and rewrote the image.

Nothing happens…

This is the serial log:

[0000.126] [TegraBoot] (version 00.00.2018.01-l4t-33e7fa82)
[0000.131] Processing in cold boot mode Bootloader 2
[0000.135] A02 Bootrom Patch rev = 1023
[0000.139] Power-up reason: pmc por
[0000.142] No Battery Present
[0000.145] pmic max77620 reset reason
[0000.148] pmic max77620 NVERC : 0x40
[0000.152] RamCode = 0
[0000.154] Platform has DDR4 type RAM
[0000.157] max77620 disabling SD1 Remote Sense
[0000.161] Setting DDR voltage to 1125mv
[0000.165] Serial Number of Pmic Max77663: 0x123e8
[0000.173] Entering ramdump check
[0000.176] Get RamDumpCarveOut = 0x0
[0000.179] RamDumpCarveOut=0x0, RamDumperFlag=0xe59ff3f8
[0000.184] Last reboot was clean, booting normally!
[0000.189] Sdram initialization is successful
[0000.193] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.199] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.205] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.211] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.217] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.223] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.228] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.234] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.250] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0000.256] Platform-DebugCarveout: 0
[0000.260] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.265] Non secure mode, and RB not enabled.
[0000.272] Invalid GPT Partition
[0000.287] Using BFS PT to query partitions
[0000.291] failed to load NvTbootTbootCpu from (2:0)
[0000.296] re-load NvTbootTbootCpu from (4:0)
[0000.380] Csd NumOfBlocks=60579840
[0000.438] Using GPT Primary to query partitions
[0000.447] Loading Tboot-CPU binary
[0000.823] Verifying TBC in OdmNonSecureSBK mode
[0000.833] Bootloader load address is 0xa0000000, entry address is
0xa0000258
[0000.840] Bootloader downloaded successfully.
[0000.844] Downloaded Tboot-CPU binary to 0xa0000258
[0000.849] MAX77620_GPIO5 configured
[0000.853] CPU power rail is up
[0000.855] CPU clock enabled
[0000.859] Performing RAM repair
[0000.862] Updating A64 Warmreset Address to 0xa00002e9
[0000.867] Loading NvTbootBootloaderDTB
[0002.175] Verifying NvTbootBootloaderDTB in OdmNonSecureSBK mode
[0002.237] Bootloader DTB Load Address: 0x83000000
[0002.242] Loading NvTbootKernelDTB
[0003.549] Verifying NvTbootKernelDTB in OdmNonSecureSBK mode
[0003.610] Kernel DTB Load Address: 0x83100000
[0003.619] Loading cboot binary
[0005.298] Verifying EBT in OdmNonSecureSBK mode
[0005.341] Bootloader load address is 0x92c00000, entry address is
0x92c00258
[0005.348] Bootloader downloaded successfully.
[0005.540] Using BFS PT to query partitions
[0005.544] Next binary entry address: 0x92c00258
[0005.548] BoardId: 3448
[0005.553] Overriding pmu board id with proc board id
[0005.557] Display board id is not available
[0007.053] Verifying SC7EntryFw in OdmNonSecureSBK mode
[0007.106] /bpmp deleted
[0007.108] SC7EntryFw header found loaded at 0xff700000
[0007.299] OVR2 PMIC
[0007.301] Bpmp FW successfully loaded
[0007.318] WB0 init successfully at 0xff780000
[0007.322] Set NvDecSticky Bits
[0007.325] GSC2 address ff53fffc value c0edbbcc
[0007.332] GSC MC Settings done
[0007.337] TOS Image length 53680
[0007.340] Monitor size 53680
[0007.343] OS size 0
[0007.504] Secure Os AES-CMAC Verification Success!
[0007.509] TOS image cipher info: plaintext
[0007.513] Loading and Validation of Secure OS Successful
[0007.529] SC7 Entry Firmware - 0xff700000, 0x4000
[0007.533] NvTbootPackSdramParams: start.
[0007.539] NvTbootPackSdramParams: done.
[0007.542] Tegraboot started after 53278 us
[0007.546] Basic modules init took 5642522 us
[0007.550] NvTbootQspiFlashIoctl: Opcode = 1 not supported
[0007.556] Sec Bootdevice Read Time = 12 ms, Read Size = 65 KB
[0007.561] Sec Bootdevice Write Time = 0 ms, Write Size = 0 KB
[0007.567] Storage Device Read Time = 6726 ms, Read Size = 2306 KB
[0007.572] Storage Device Write Time = 0 ms, Write Size = 0 KB
[0007.578] Next stage binary read took 1526579 us
[0007.582] Carveout took -1538259 us
[0007.586] CPU initialization took 2039658 us
[0007.590] Total time taken by TegraBoot 7670500 us

[0007.595] Starting CPU & Halting co-processor

Hi NDev,

Have you ever tried to use sdkmanager to reflash the sdcard?

Hi WayneWWW,

as I wrote in the first message, among the various things, I have already tried to reformat micro sd and rewrote the image, using the instructions:

I did it under Windows using SD Card Formatter + Etcher, but if you feel it necessary I can try to use sdkmanager.

Yes, please try with sdkmanager too.

Hello WayneWWW,

I’m trying with sdkmanager, but the flush of the OS is at 99.9%… since this morning! Any idea?

hmm… Better using the native flash tool to debug it.

sdkmanage should install a folder named “Linux_for_Tegra” on your host. Could you go to that folder and run command “sudo flash jetson-nano-qpsi-sd mmcblk0p1”?

It would flash the sdcard as sdkmanager does. Please share the log with us if it get failure again.

Hello WayneWWW,

before reading your post, I tried another sd card, and the flush worked using sdkmanager. However, there is another problem: Jetson Nano doesn’t recognize the Pi Camera V2 (…it worked before!). No /dev/video0… No video if I launch:

gst-launch-1.0 nvarguscamerasrc ! ‘video/x-raw(memory:NVMM),width=3820, height=2464, framerate=21/1, format=NV12’ ! nvvidconv flip-method=0 ! ‘video/x-raw,width=960, height=616’ ! nvvidconv ! nvegltransform ! nveglglessink -e

Obviously, I plugged and unplugged the camera several times.

The same camera works on a Raspberry Pi 3…

Hi NDev,

If this is another topic, please file a new topic instead of using current one. Thanks.

Hello WayneWWW,

could I directly rename this topic in “Does Not Work Properly”?

In fact, in addition to what I wrote in the last post, I can tell you another strange thing: with the new sd card, too, the flash doesn’t work with etcher, just with sdkmanager. But I did the first flash (with the old sd card) using etcher!

So, the story so far is:

  1. format and flash os with eatcher: everything worked well for two days, including a Pi Camera V2;
  2. the third day, screen remained black;
  3. re-format and re-flash sd with eatcher: screen remained black;
  4. flash using sdkmanager: stopped at 99.9%;
  5. change sd, flash os using eatcher: screen remained black;
  6. using the new sd, flash os with sdkmanager: worked, but doesn’t recognize the Pi Camera V2 (the same camera works on a Raspberry Pi 3).

The whole story is very strange.

Ok, it is fine, if camera is the only issue here.

Could you share the failure (full) log and the working log (do you keep it?) of your camera?

How can I obtain these logs? I just put the camera in the J13 connector and siwtch on the Jetson Nano: than, there’s no /dev/video0. Do you mean the serial log with the uart debugger?

Yes, I mean the uart log.

hello NDev,

you should include some specific drivers and device tree to enable Raspberry Pi camera support.
my suggestion is… you should narrow down the issue and check which part is missing.
then, please back-up your environment as last-known-good. you may also refer to Topic 1044148 for the steps to backup and cloning.
thanks

Now, no uart log is produced. I follow the same method:

https://www.jetsonhacks.com/2019/04/19/jetson-nano-serial-console/

I’m absolutely speechless…

Does the power indicator (LED) still work? Could you remove all peripheral and see if uart log can come out?

Does the system still boot into ubuntu?

Yes, power indicator remains green. No peripheral device is attached.

Yes, the system still boot into Ubuntu.

Then I think it is UART debugger setup/configuration issue.

Using the same machine, the same program (minicom), the same usb to ttl serial cable, I can read from other devices: for example, I tested it with a Esp32 Cam, and it works.

Then I guess the Jetson Nano itself has some problems…

Could you try to flash the board and see if any log comes out from uart during flash process?

I’m just re-flashig os using sdkmanager (same sd), the uart debugger is attached: no log from minicom.