Can't boot up Jetson Nano after flashing new image on SD card

I flashed the new image on SD card, then my Jetson Nano just couldn’t boot up. I can see the LED is green, but it doesn’t blink.
Can I get anyone to help me?
Attached photo is my Jetson Nano with LED green.

If you have the cable, you can dump the log.

If you don’t have it, please directly flash your board with sdkmanager.

I tried directly flashing my Jetson 2GB Nano from Ubuntu 16.04 but didn’t work. It appears the SDK can only update on a previously flashed board. I was able to update my Jetson 4GB Nano to Jetpatck 4.6.2 with SDK Manager. BTW, the 2GB board behaves the same way (i.e., stuck at splash screen) without the microSD card inserted.


It appears the SDK can only update on a previously flashed board.

I have no idea about what you are telling here. This is wrong. Please clarify what does that “didn’t work” mean here. Cannot flash? or flash is done but you hit another issue?

BTW, the 2GB board behaves the same way (i.e., stuck at splash screen) without the microSD card inserted.

I don’t see any error in this sentence either. The system needs the sdcard to boot, without card, of course it would get stuck. What do you expect it would show here?

Also, are you coworking with the original owner of this post? If not, how about you file own topic?

Likely that you just need to flash the bootloader. You can do this via the SDK Manager.

You will need a header connector as you will probably need to put the board in Forced Recovery Mode by shorting pins 9 and 10 on the button expansion pins when you boot up.

You will need a PC that is running Ubuntu 18.04 LTS to perform the flash on the Nano.

Hi @WayneWWW , thanks for your reply.
How I initially flashed my sd card was using balenaEtcher. And when I inserted this sd card to my Jetson Nano, my Jetson nano just couldn’t boot.
So you proposed to use SDK manager, does that mean I need to connect my Jetson Nano (with sd card inserted) to my Ubuntu PC? If so, how can I connect my Jetson Nano to my Ubuntu PC?

Hi @WayneWWW @Dingo_aus
Thanks for your reply :)
When I connect my Nvidia Jetson Nano to My Ubuntu PC using micro-usb to usb cable, my PC just can’t detect my Nano (Even-though Nano power LED is green as shown in the following photo). Is there any steps I’m missing?
This photo shows how I connect Nano to my PC:

This photo shows JDK can’t find my Nano:

This photo show lsbusb can’t detect Nano:


I think you have missed the step of booting the device up with pins 9 and 10 of J50 shorted. When these are shorted on boot, it puts the Nano into Force Recovery Mode and that is what the SDK Manager is actually looking for.

J50 on the B01 are the horizonal pins below the SD card.

Once you boot with it, SDK Manager will detect and then you remove the header.

(it is a manual way of having a button that you press and hold whilst booting on some other boards)

BTW make sure you force SDK Manager to keep using Manual Setup. Once it see the heartbeat it defaults to Automatic Setup. You still need to use manual setup until it is flashed.

I have jumped the reset pin shown in the photo, my ubuntu still cant detect it :(

Jumper pin looks correct.

Maybe try another usb micro cable, just in case that cable is power only and doesn’t have wires connecting data pins. (or the cable is broken).

…and maybe try a different USB port, preferably one on the motherboard in case the Case Cable is not attached in you PC.

Have tried different usb cables on different usb port on my ubuntu machine. Still had no luck…

Now i highly suspect there maybe some hardware failure happing inside the Jetson Nano…. The power LED is always green, but not sure where could be the problem.🥲

I would suggest pulling all the cables out, re-reading the steps and try it from scratch.

You need to have the pin 9+10 jumper on when powering on the board, then plug in the usb then remove it.

I would also reset the SD card by putting it in a card reader, opening gparted in Ubuntu and deleting all partitions on it and replacing it with a single ext4 partition.

With all the steps, it might pay to take a video showing everything. Getting one thing wrong usually means it won’t flash or be detected.

You could also post the SDK Manager logs.

Instead of “pre-config” in the sdk GUI, try with “manual config”.

Hi @Dingo_aus , I tried in following steps:

  • deleting all the partitions on SD card and replacing it with a single ext4 partition.
  • put the Nano on Recovery mode by jumper
  • connect to Ubuntu using USB cable
  • remove the jumper

My host Ubuntu machine still can’t detect Nano by running lsusb.

@WayneWWW I tried instead of “pre-config”, error persists since my Ubuntu machine still can’t detect Nano by running lsusb

Looks like my Nano is broken, probably I have to buy a new one …
To be honest I have spent 2 entire days working on this issue 😔, and I really want to know what’s actually happened to my Nano. But it’s really unfortunate that I can’t find a repair centre for Nividia Jetson Nano in Melbourne 😞

You can try to boot up the board first and try to dump the uart log.

I don’t actually think the board is broken. Most of cases I’ve seen are the host side problem, do you have other jetson devices that can validate your host and your micro usb cable?

If you ubuntu host a VM?