Jetson Nano unbootable

I have just bought a Jetson Nano and it is completely impossible for me to start it.

I’ve managed to get the Nvidia logo but it’s impossible to go any further.

I have tried with all the images that exist in and none of them make it start, all of them are black screen or with the logotipod and nvidia.

I have 4 SD 2 of 64gb and 2 of 128gb, with none of them it starts.

I have 2 chargers, one of 4a official that indicates on the web and another of 3a that I usually use in a raspberry Pi 4. But impossible, I can not get past the logo.

I have followed all the instructions on the web, formatting and everything with the official software, but impossible.

I have tried to do everything from windows 11 creating the images and so on as indicated in the guide but nothing.

I have read many posts with this problem but I can’t get anything. I can not connect via USB to the serial port, with putty, it seems that it does not exist.

It is the JetsonNano 2gb version with USB-C port.

Can you advise me? I’m desperate.

Thanks in advance.


It is not possible to fix your issue by keep replacing the sdcard. You need to reflash your board by setting up another ubuntu 18.04 x86 host and install sdkmanager.

Use sdkmanager to relfash your board.

Basically, point 0 of below post.

I can’t even get the jetson nano to boot with ubuntu.

I don’t understand what it tells me I have to do.

If I can’t even boot it with ubuntu how am I going to install anything.


Yes, I know your jetson cannot boot. Sdkmanager is not installed on your jetson. There is no such “jetson flash jetson itself” thing. Sdkmanager is running on x86_64 host and then use usb connection to flash your jetson.

I already mentioned x86 host 3 times … if you still don’t understand about it, please tell.

I still don’t understand what I have to do.

This is the picture of how sdkmanager work. You need to install your sdkmanager to another host PC. Use usb connection between host PC and your jetson nano and it will flash this way.

I hope this “host PC” word can make you understand what x86_64 host is…

FYI, the models NVIDIA provides are dev kits. They have the SD card on the module itself, not on the carrier board. Instructions differ compared to models provided by third parties whereby the SD card is on the carrier board. Assumptions here include the Jetson in question being a dev kit. You might want to verify the SD card is on the module and not on the carrier board.

An added point to clarify: The SD card has the operating system on it. However, the SD card does not have the boot content on it. There is QSPI memory on the Jetson itself. This is used for something equivalent to the BIOS and boot content. This actually gets flashed separate from the SD card. It sounds like the QSPI needs to be flashed to a release compatible with what your SD card has. To do so follow the instructions in the URL for the specific release of JetPack/SDK Manager. This requires installing to an Ubuntu 16.04 or 18.04 host PC (Jetsons don’t have a BIOS, so they cannot self-flash).

For terminology, JetPack is a GUI front end to the actual flash software (and SDKM is the network utility on top of JetPack). This is what flashes the QSPI content, but the actual flashed content is called “Linux for Tegra” (“L4T”; Ubuntu plus NVIDIA drivers). The version of L4T provided is tied to a version of JetPack, and so the designations, while being different, are basically equivalent. The Nano (assuming it is a dev kit) can use any JetPack version 4.x (L4T version R32.x). See:

Thanks for the answers and the speed of them, but, when I try to use the sdk manager from Ubuntu 20 and 22, just when I try to connect to the Jetson Nano 2GB development Kit it tells me that the host is not supported.

Which version of ubuntu should I use 18 or is this problem due to another bug?

You cannot use Ubuntu 22.04 with any Jetson flash (at least not yet for JetPack versions 5.x or earlier). You cannot use Ubuntu 20.04 to flash a Nano. You have to use a host PC which is either Ubuntu 16.04 or 18.04 for a Nano (which corresponds to a JetPack 4.x release). I highly recommend 18.04.

This is not a bug. It is a limitation of what is being flashed. There are other non-Jetson hardware devices which do work with an Ubuntu 22.04 host PC, but each Jetson adds an additional limitation to host PC release version depending on what is actually getting flashed to the Jetson. JetPack itself is just a GUI front end to the actual flash software (called the “driver package”, which flashes L4T). You could possibly flash on command line with an Ubuntu 22.04 host PC (which is less versatile and more manual), as this is mainly a GUI limitation and not the actual driver package limitation.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.