Jetson Nano not working

Hi! I have an issue regarding my Jetson Nano. Apparently, I got a replacement from Nvidia just recently and tested it using a working SD Card (works on another Jetson Nano) but it doesn’t boot up and nothing appears on the screen. However, the green LED is lighted up and stays on. I chatted with the live agent about this and I asked for another replacement but they told me to ask the forum for suggestions to settle the issue. One way I tried myself was to factory reset the Jetson Nano but it still did not boot up. The power supply used is the DC power supply and adaptor used is the one provided by NIVDIA themselves. I also tested the adaptor with another Jetson Nano and it is working so definitely not adaptor problem. We also tried to use a Micro-USB cable to switch on the Jetson but still not working. Is there anyone who can help me regarding this issue? Thank you and hope to hear from you soon.

You need to flash the board with sdkmanager.

It seems you misunderstood the meaning of “factory reset”. That recovery mode is to put the board into a state that it can get reflashed by sdkmanager. There is no “just click a button and the board will be back to life magic”.

And some explanation to why flashing with sdkmanager will work. This post has nothing to do with your issue. Just need to check this comment.

yes i factory reset the board and after that flashed using sdkmanager. But in the first place, before I factory reset the Jetson Nano, I do not understand why a working SD card does not work on the new Jetson Nano that I receive. It was unable to boot up at all but it is new.

And, I know just factory resetting the board doesn’t make it come back alive. That’s why I also flashed using the sdkmanager and even flashed a new OS image into the SD card.

Is the board able to work now or it is still dead?

Sadly, it is still dead

Please dump the uart log.

Also, are you sure your board is re-flashed with sdkmanager successfully?

Hi, I do not have that cable to connect the serial port header. Yes, I tried it in campus a few weeks ago but I am unable to go back campus at the moment so I do not have a Linux host machine to run the sdkmanager. Currently, I flashed a new OS image to the board, will it not work?

I don’t know either.
It is not possible to tell if you cannot provide log.

I flashed a new OS image to the board, will it not work?

What kind of “flash” do you mean here? Sdkmanager or sdcard image? Generally, I use “flash” word only when using sdkmanager. I don’t consider sdcard image as a “flash” since it actually not flash anything to the board…

I formatted the SD Card and also use the BalenaEtcher to write in a new image from your official website and slot it back into the Jetson Nano and tried to boot it up again.

Because right now, I don’t have the Linux Host Machine and we don’t understand why a new Jetson Nano does not work at all when our other ones are working.

I can only suggest you to find a ubuntu host to flash it first.

Whether it is a hardware problem depends on your result after sdkmanager flashes it.

Is there no other alternative? This is because not everyone has a ubuntu host to flash it, the common operating system using is still Windows or MacOS.

Sorry that there is no alternative.

Just to check with you, since the Jetson Nano is still under warrenty, is it not possible to get a replacement from your side?

Actually this is out of what I can respond. I can only help you with technical problem regarding flashing, booting or help you to check your log.

If you want to use jetson nano, my personal suggestion is you should prepare a x64 ubuntu 18.04 host to prevent such issue.

Hi, I understand where you are coming from but I have been using another Jetson Nano and there wasn’t any issue with the booting up even if I didn’t use the sdkmanager with a Ubuntu host machine. But, I am unsure why this Jetson Nano is so different and requires a host machine to boot it up. Is there any explanation on this?

Actually, without a log, all I can tell are guessing…

The possible causes are:

  1. this jetson nano has hardware problem.

  2. If this jetson nano is able to work before, and now it suddenly not work anymore. It means something corrupted the bootloader software.

  3. The factory does not install the bootloader sw correctly.

  4. The bootloader sw that installed by the factory is too old.

Okay I see, thank you.