Problem with JetsonNano DevKit 4gb (wont boot)

Hello guys,

i have bought and successfully configured/used several jetson nano boards this year(about 15 boards).
i am having problems with 2 boards
the other boards S/N starts with 1423… 142311…

i usually, clone an sd card (always the same size brand etc) which contains my program and some network configurations in it (samba etc…). and it always worked until now…

About the procedure i have done on all the boards:
1 - write a image downloaded from NVIDIA and install it to make sure that the board works
2 - erase the sd card then write the clone of my main sd card to it
3 - it usually boot (except for the 2 boards above), then i refresh ssh keys and etc for security
what happens this time is, after icloned the sd card the jetson nano DIED… it wont show the NVIDIA logo
even with a fresh new sd card with a recent or older image downloaded from NVIDIA website…
the green led turns on, and i can put the board on recovery mode but i cant boot even flashing from sdk manager…

am i bricking the boards with my method?
what should i do?

thank you in advance.

If you want others to help analyze what happens to your board, you can dump the log from serial console.

If you want to a quick method to resolve your issue, then please find a x86 ubuntu 18.04 host and try sdkmanager.

1 Like

thank you for replying me.
i will try it and post the results here.

thanks again

DCU-bootlog-SN1020121044148 (2.1 KB)
DCU-bootlog-SN1020221056390 (2.1 KB)
here is the logs i dumped using serial console.

Both modules have broken content inside the QSPI. The only solution is using the sdkmanager.

hello Wayne,
i have tried the sdkmanager but, no success…
any other suggestions ?

Maybe you can tell more about what is “no success”. Any flash log to share?

Hi WayneWWW,
thank you for your fast reply.

I dont have any flash log to share right now but,
i just saw in another topic ( Jetson Nano does not boot up - #6 by english0815 ) that using a VM with sdk manager can cause some error while flashing…
i’ll try to flash with sdkmanager again from a host machine and see whats happens then i post my flash logs here.

thanks again.

hmm… I think you can enhance your way to describe current situation.

Your first description sounds like “sdkmanager does not work for such case, issue is still there after you flash”.
But actually it turns out you didn’t successfully flash at all. This is totally different.

Honestly, I have seen over 10 topics which share the same error log as your case. All of them could be resolved by flashing with sdkm.

i understand. i’m sorry, my mistake.
i’ll check again and give you more concrete info.
about my current situation, i flashed once with Balena, then i tried sdkmanager on a vm
and today before i send you the logs i used Balena again.
next i will try sdkmanager on a host machine and see if i manage to make the board work again.

Balena will not save such situation. Changing SDcard will not restore the content over QSPI.

Save your time and directly find a dedicated 18.04 ubuntu host for sdkm.

1 Like

i am working on it right now.
I’ll let you know my results, thank you.

Hi WayneWWW,

i was able to solve the problem flashing with sdkmanager from a dedicated Ubuntu 18.04 host machine.

thank you very much for your support.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.