Jetson Nano Username Password

I recently bought a Jetson Nano 2GB. I am trying to bring up the board for the first time and have followed the instructions as per Getting Started with Jetson Nano 2GB Developer Kit | NVIDIA Developer. When I put the SD card into Jetson and connect it to the Monitor, I am being asked for ID and password. Any help? I tried multiple times with multiple SD cards, starting fresh. I am getting stuck with the same thing.

1 Like

Which version of sdcard image are you using here?

Also, what is the tool you use to install the sdcard image?

Could you also download a fresh image from the website again instead of using the same image to flash all the sdcards?

Hi, thanks for the reply. The cards i am using are HC I and XC I. 32GB and 128GB respectively. Tool for installing the image on sdcard is balena etcher.

I just tried downloading fresh image again. Same issue again. While booting up the first time, this error comes up. (please see the picture)

I am not sure why some users would hit this but I just tried yesterday, and no this issue on my side.

What is the version of your Balena Etcher?

yeah, it is weird. But i am arriving at the same problem despite new sd cards, fresh image etc. The only thing that is not changing here is the jetson nano. I am using the latest etcher. I think 1.7.7.

Solved this by installing an older version (4.5] from the archive. Thanks.

1 Like

Hi @dheemanth11 ,

Just an experiment, after you tried jp4.5, could you move to jp4.6.1 again? I think the issue would be gone in jp4.6.1 after jp4.5 upgrade some software on your board.

Having same issue - where do we download jp4.5? I went to downloads but that is only the 4.6.1 version, and in the archive when I click on Jetson Nano it says No downloads meet your criteria. Filtering by Product: Jetson Nano.

Hi,

Not sure if you are willing to dump the log before running other version of the sdcard image?

I don’t have the right serial port for this, sorry. I did load sdkmanager and try to flash 4.5.1 but with the 4.6.1 boot config problem (basically attempting to go into config mode somehow errors out behind the scenes)) then it seems to ignore the pin 9 to pin 10 force recovery mode being shorted out. So as sdkmanager doesn’t generate an image I can flash, I need to download a 4.5.1 or earlier image.

Are the images just missing because of the documentation and download issues? For ages I couldn’t even get the 4.6.1 latest to download.

Find the archived downloads here: JetPack Archive | NVIDIA Developer

Hi,

I am not quite sure about your comment here.

I did load sdkmanager and try to flash 4.5.1 but with the 4.6.1 boot config problem (basically attempting to go into config mode somehow errors out behind the scenes)) then it seems to ignore the pin 9 to pin 10 force recovery mode being shorted out

SDKM does not read the software that pre-installed on the board. It will format it no matter what was pre-installed on the board.

If you cannot make it flash the board, it is probably some operation error or compatible issue. For example, if your host machine is a VM, then it may not able to detect the jetson. Also, if the board is not in recovery mode, host cannot flash it.

And just some explanations about this issue.

  1. First, the jetson nano module has a QSPI-NOR flash. This device has bunches of bootloader software. The reason we can insert a sdcard image and let it boot is due to this software. This software was pre-flashed by factory.

  2. The problem here is: It seems rel-32.7.1/jetpack4.6.1 is not compatible with specific version of bootloader.

  3. The methods to workaround this:

method 1: directly flash sdkmanager with jetpack4.6.1. Unlike sdcard image, sdkm will update the bootloader in QSPI, which means this incompatible problem will no longer exist.

method 2: put a sdcard image >= 4.5.1 jetpack version(except 4.6.1). Because new release like 4.5.1/4.6 sdcard image is able to update the QSPI bootloader after it boots up and takes about few mins to update the bootloader software. After this, you can even use jetpack4.6.1 image again and it shall be fine this time.

And the reason why we need your help is because we cannot really know the exact version that hit this issue. If you are not able to share serial log, please at least share me the syslog (/var/log/syslog) right after you try method 2.

The bootlaoder update log will be saved in syslog and we can know what is going on.

1 Like

Thank you for helping. Because I can’t log into the jetson - it fails to do the auto configuration and no user or password is setup. It then asks me for a username and password that doesn’t exist so no login to get logs. I am now going to flash 4.5.1 image and I hope that will work.

Regarding sdkmanager, can I flash a micro-sd on the sdkmanager host? I couldn’t find any option to do this (but the link to the archive is very useful).

Finally (for the moment) suggestions for navigation improvement:

  1. Jetson Download Center | NVIDIA Developer could use a link that pointed to the jetson nano archive (e.g. click here to download version 4.6.1 or click here to go to the jetson nano archive)

Or

  1. This page Jetson Download Center Archive | NVIDIA Developer should have the jetson nano / xavier downloads or at least reference the other archives
1 Like

Sorry that SDKM can only flash the sdcard when it is inserted in the jetson.

No worries - the jetson refused to run and refused to go into recovery mode and the sdkmanager didn’t have the username and password, so it was a like a small crop circle. I really appreciate the great support. Do you want any logs if it does manage to boot 4.5.1? As it’s for a jetbot I probably won’t upgrade jetpack to 4.6.1 just yet.

Hi,

I think you can provide a picture of how you put your board into recovery mode.

Honestly, “Refuse to enter recovery mode” is unlikely to happen. In most of case, it would be more like incompatible issue. For example, your host machine could not be a VM.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.