Jetson Nano Stuck at Nvidia Logo Screen

Hello,

I’m having issues booting up my Jetson Nano. I followed the instructions using the Getting Started
(Getting Started With Jetson Nano Developer Kit | NVIDIA Developer)

I’m also using the recommended PSU. (Raspberry Pi 4 Power Supply USB-C 5.1V 3A) based on the recommendations listed here:

I tried a few SD cards including Sandisk, Patriot, Lexar - with no luck.

How can I get this working?

Will it work if you use sdcard image from here?

Update - Trying the latest image dated February 24th works.

Thanks

Are you using the Nano 2GB or 4GB module?
It seems the link are not the right one at your first, could you help to confirm again?

Thanks

The 2GB module.

jetson-nano-2gb-jp451-sd-card-image.zip

Hi. I’m facing the same issue. Still, haven’t try flashing a new SD. However, I would like to know if it’s another alternative without flashing the SD since I don’t have back up of some files that I deploy on the board.

Hi aldiaz,

May I know the sd image link you used?

This one the one provided in the Starter Kit Guide https://developer.nvidia.com/jetson-nano-sd-card-image

The same image is working in a new SD but I don’t have the files. Is it possible to somehow recover the files on the SD that doesn’t boot?

I can’t get what you mean.
You mean some SD cards can boot successfully and some cards can’t?

Yes I have two SD cards with the same image one boot succesfully the other one doesn’t. However on the SD card that doesn’t boot I’ve the latest versión of some files I’ve been working. Is there a way to recover those files?

Could you dump the uart log from device during boot up failure? I want to know what is the exact error there.

Mount the bad card with a card reader and copy the files. I have been struggling with getting a stable sd card so I know this works.

I am also encountering the same issue. I have the 4GB B01 model with iso sd-blob-b01.img.

It worked fine throughout the week and then all of a sudden yesterday the terminal wouldn’t work and everything locked up. Naturally, I reset the machine and it would lock up at the logo. I kept getting squashfts errors.

I am guessing I either, have the wrong iso image for the Jetson Nano or the 400GB SD card is capoot! There is a way that I’ve been able to bypass the lock up on the logo screen and that’s with pressing and holding Alt + Ctrl + Del where you might have to do it a couple of times.

If anyone has encountered the same issue, this might be a temporary solution to be able to log into the Jetson Nano when it locks up. From what I’ve encountered, it’s going to happen all the time but at least you will be able to access your files or even save them to a usb.

Hope that helps.

1 Like