Jetson Nano P3450 B01 4GB RAM stuck on nvidia logo screen

Hello All,

I just got a new Jetson Nano P3450 4GB RAM NVIDIA Jetson Nano Developer Kit (945-13450-0000-100), by hindsight I formatted and flashed (balenaEtcher) a 128 SD Card with the which had the sd-blob.img (this was for the 2gb model) and then once plugged in and powered via the micro usb, it started and it went till the ubuntu desktop and after a minute or more it asked to reboot and I did and then it got stuck on the nvidia logo and does not complete loading. I later downloaded the which has the sd-blob-b01.img (the one for the 4GB model) and wrote that to the SD card and plugged that in hoping that it would boot and I could get it working , but its stuck on the nvidia logo screen.I cannot see what the loader is doing , it tries and goes black after some time but comes back to nvidia logo screen.

I thought it was something to do with the SD Card I tried three models toshiba 128 v30c3msdxc, lexar 128c1 and sandisk 32 utlra but still stuck on the logo and cant see what’s the issue.

I feel the first successful load and restart has written ??? something ??? to the board ??? and its stuck cause
the first image was for the 2gb one and not for the 4gb one ???

Is there any way to come out of this situation , I am in a windows environment at the moment.

Can I reset the board and if there is something that gets erased and try over again ?

Can someone advice on the steps in this case.


hello abm_v,

please gather bootloader logs via serial console for more details,
you may refer to Jetson Nano - UART - JetsonHacks for setting up the environemnt.

Thanks for your reply, I bought a cable and followed the video here Jetson Nano - Serial Console - YouTube and managed to gather the bootloader log as below (attached) . its stuck starting kernel

I used the jetson-nano-jp451-sd-card-image (sd-blob-b01.img) on a sandisk 16gb micro sd hc1 c4 basic disk just be check if its a card used the balenaEtcher/sd card formater

please note my above orginal post and below log please have a look at the log and suggest what to do, thank you for the help

23062021_jetson_nano_p3450_b01_4gb.txt (32.8 KB)

according to Topic 180796, could you please have a try to flash the board with flash script.

Dear Jerry,

Thank you for the prompt reply, Can you please advice the steps to do this as I am a bit new to this. As far as I go I have a ubuntu desktop with the Nvidia SDKManager on it.

If I am to use SDKManager to do what u mentioned , how to I connect the Jetson Nano P3450 B01 to this desktop ? I have the uart cable ? Currently I have powered the model with 5 v 2 a power adapter to the mini usb port.


please see Jetson Nano Developer Kit User Guide for reference, thanks

I had to downgrade to ubuntu-18.04.5-desktop-amd64.iso (do update for base components) and install the Nvidia SDKManager as it was the one that was supported by the SDK manager at the moment and managed to flash the device after putting the jumper on recovery pin, giving direct power to barrel jack and connecting the device to USB port of the workstation using a USB to mini USB cable.

The SDK manager worked and had to select the model to perform operations on , it downloaded the files from the internet and flashing took some time and was held at 99% and later finished. ( though the sdk components part didn’t work i skipped that after it didnt for some reason (maybe it had to write to SDK card?)

Then I removed the jumper of the recovery mode and restarted the device and it worked. it booted off the SD card and it started the initialization and EULA screen again.

NOTE: If you remove the SD card and boot the device the Nvidia screen appears but it shows
a no SD Card logo on the to right also.

If you have a another SD card also with the correct image you can put that in and it will look like you start a new again with the EULA screen etc.

So beware to start with the correct image else you will end up doing all this just to get restarted again

Hope this message helps someone else.

1 Like

@abm_v, I am in exactly the same predicament. Would you happen to have an image on what the recovery pin looks like?

Found it! :)