Cannot Boot Jetson Nano 2GB for the first time

Hello, I have tried to install the Jetson 4.4 / 4.6 onto my Jetson nano 2GB developer kit. During Boot it is always stuck on the Nvidia Logo page. I’m not sure where I’m going wrong with the OS installation. I have followed the video tutorial to the dot.

Tutorial Link:

Jetpack OS versions tried:

Any help with this is much appreciated !


Hi madhava.vemuri,

Please try download the Nano 2GB SD Card Image from:
Follow Getting Started with Jetson Nano 2GB Developer Kit steps to flash image to sdcard.

Hi @carolyuu, I have re-installed the flash image again. It is still stuck on the Nvidia logo.

Hi madhava.vemuri,

Please share the uart log for check.

Hi @carolyuu,

How can I do that ? I’m connecting the HDMI cable directly to the nano development kit. Where can I check the UART log ?

Hi madhava.vemuri,

Please connect TX/RX cable to J12 pins.
Reference link: Jetson Nano 2GB Developer Kit User Guide | NVIDIA Developer

Suggest you can change another sdcard and using Etcher tool to flash sdcard image again.

Hi @carolyuu, I have mixed and matched 2 boards with 2 different SD cards, the issue is still persisting. I’m not sure how to check the UART log with my laptop, any suggestions ?

Hi madhava.vemuri,

What Etcher tool version are you using?
Are you run Etcher tool on Linux host machine or Windows?

Suggest you can format your SD card to ext4 and re-download the SD Card image and try again.

Hi @carolyuu,

I’m using a Windows host machine to etch the OS using the balena Etcher. I’ve also tried using the sdkmanager in Ubuntu 18.04. even in that it is not able to detect the Nano board. I tired using the Force recovery mode, it did not work either to detect the board.


Please check if your micro usb cable really has data line but not just power line.

I am also facing the same problem( can’t boot ) with the jetson nano 4Gb dev kit.

Im using NVIDIA documentation i.e Getting Started With Jetson Nano Developer Kit | NVIDIA Developer

and the USB cable that comes with TX2 kit.

i also tried with other jetpack( jetpack 4.4 and 4.5), but encountering same problem.

please share me the lsusb result on your host after you put the board into recovery mode.