After SW update the boot of Nano 2gb hang

Hello, I use the Jetson Nano 2gb development board a view days. At beginning it worked all propper. But after the last software update (a normal sudo apt-get upgrade) the board hang at boot sequence. The Nvidia screen shows up for few seconds and after that the board seems to restart. Flashing a new SD card not help. It shows the same behaviour.

Any suggestions?


I won’t be able to answer, but if you have a serial console boot log it should point to whatever package “went bad”. See:

You might also mention which JetPack or L4T release this has on it, and verify if it uses the dev kit carrier board.

Also, mention if you used JetPack/SDK Manager to flash, or if a preexisting image was used.

1 Like

What was the software release you were using before running apt-get upgrade?

Please dump the log as linuxdev’s comment.

Many thanks for your comments.
I used jetpack 4.5.
I setup the serial consoleow , and I am able to see booting messages.
The last messeges are:
Booting using the fdt blob at 0x83100000
ERROR: reserving fdt memory region failed (addr=0 size=0)
ERROR: reserving fdt memory region failed (addr=0 size=0)
Using Device Tree in place at 0000000083100000, end 000000008317e68d
copying carveout for /host1x@50000000/dc@54200000…
copying carveout for /host1x@50000000/dc@54240000…

Starting kernel …

[ 0.000000] Booting Linux on physical CPU 0x0
[ 0.000000] Linux version 4.9.201-tegra (buildbrain@mobile-u64-5294-d8000) (1
[ 0.000000] Boot CPU: AArch64 Processor [411fd071]
[ 0.000000] OF: fdt:memory scan node memory@80000000, reg size 48,
[ 0.000000] OF: fdt: - 80000000 , 3f800000
[ 0.000000] OF: fdt: - bfa00000 , 3fe00000
[ 0.000000] OF: fdt: - ffa00000 , 600000
[ 0.000000] earlycon: uart8250 at MMIO32 0x0000000070006000 (options ‘’)
[ 0.000000] bootconsole [uart8250] enabled

After that it stop nothing more happen.

Please share me the full log.

Its very big, how can I post with scrollbars?

There is a button to attach/upload file when you typing your comment on forum.

Many thanks for your help.
Here it is the full log:

boot_log.txt (17.7 KB)

1.Is there anything shown on the monitor?

  1. Did you have any customization on this board before? For example, let it boot from external storage?

I see only the Nvidia logo, nothing else happen. The board is at origin configuration.
I setup a 64gb SD card with disk imager and was able to steup the Nano. I installed with apt-get opencv and tensorflow and few other packages. it worked all propper. Than I performed a update(with the sudo apt-get upgrade/update). I saw that some new kernel files was updated. I reboot after update and the nano hang at boot at Nvidia logo.
I try to flash a new SD card with Image who earlier worked, but no effect. Meanwhile it is Jetson 451 image available, but it not work either.
I not attached a external storage. During first installation process it was a USB cam and a Raspberry cam attached to the board.

If you want to re-install the device, please use the image from dlc.

Some other users tell me the image from “Getting Started with Jetson Nano Developer Kit.” has problem.

Hi franky67th,

I tried to OTA upgrade from JP-4.4.1 to JP-4.5.1, there are no issue on Nano-2GB.
List our steps for you reference:

  1. Change the repository name and download URL in the deb commands:
    $ sudo vim /etc/apt/sources.list.d/nvidia-l4t-apt-source.list
    deb r32.5 main
    deb r32.5 main
  2. Enter the commands:
    $ sudo apt update
    $ sudo apt dist-upgrade
  3. After upgrade completed and reboot system, system can boot to Desktop success.