Boot Error - Stuck on splash screen

I have run into a similar issue to this forum post, where a 4GB Jetson kit is stuck on the splash screen: Jetson Nano Developer Kit (4gb) doesn't boot after System Update (only shows Nvidia Logo) - #4 by domi

The log dump appears to have an error in which the hardware thinks it’s the 2GB kit, but has 4GB of RAM:

SoC: tegra210
Model: NVIDIA Jetson Nano 2GB Developer Kit
Board: NVIDIA P3541-0000

Whereas, this is what the working boards show in their log dump:

  • Normal 2GB:

    SoC: tegra210
    Model: NVIDIA Jetson Nano 2GB Developer Kit
    Board: NVIDIA P3541-0000
    DRAM:  2 GiB
  • Normal 4GB:

    SoC: tegra210
    Model: NVIDIA Jetson Nano Developer Kit
    Board: NVIDIA P3450-0000
    DRAM:  4 GiB

Apparently, you can only attach one link per post. I’ll attach the log dumps from each board with this issue seperately:
failure-04.txt (20.7 KB)

2nd board:
failure-06.txt (20.7 KB)

3rd board:
failure-06-1.txt (20.7 KB)

Hi santaimpersonator,

Are you using the devkit or custom board for Jetson Nano?
If you are using the devkit, have you tried to flash the devkit with SDK Manager?

What’s your power adapter for the board?
Or you are using micro-USB as the power source?

Hey Kevin,

This is for the 4GB Jetson Nano dev kit: NVIDIA Jetson Nano Developer Kit (V3) - DEV-16271 - SparkFun Electronics

I’m using a Jetpack 4.5 image for the Jetbot, which should be compatible with boards that have and do not have the updated firmware flashed on them.

I have not tried using the SDK Manager to flash the boards yet. This is for a customer order, in which they claimed to have an out-of-the-box problem. After several attempts at some basic troubleshooting on their end, we got their boards back and eventually found this discrepency in the bootloarder messages of their boards.

I’ve tried powering the all the boards both through the micro-USB connector (5V/3.5A wall adapter) and the barrel jack with a variable power supply (set at 5V@4.5A).


Please use latest sdcard image and try again.

By default the kernel log in UART is in silent mode so if you could remove the quiet from /boot/extlinux/extlinux.conf, it might help.

The image I am using, appears the same as the one linked in the getting started guide: Getting Started With Jetson Nano Developer Kit | NVIDIA Developer

Then it requires further debug as I said. Need to enable full log.

Hey Wayne,

I modified the /boot/extlinux/extlinux.conf file on the SD card and removed quiet from the APPEND label:

extlinux.conf (839 Bytes)

DEFAULT primary

MENU TITLE L4T boot options

LABEL primary
      MENU LABEL primary kernel
      LINUX /boot/Image
      INITRD /boot/initrd
      APPEND ${cbootargs} root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0

However, now none of the bootloader messages get passed through the serial console. I restarted the Jetson several times, waiting a few minutes longer each time. I’ve also tried this on another of the boards with the same issue.

Though, I am pretty sure I saw part of the kernel log was in the text files that I linked in my previous responses.

You can share some log to me so that I can check why this happened.

If you are talking about nothing gets printed, then it must be setup issue. Bootloader log can be printed even without sdcard inserted.

A change in some sdcard file won’t make it dead.

Yes, they are linked in my previous responses:

Yup, one of the jumper wires was loose… go figure. These are the bootloader messages, with the /boot/extlinux/extlinux.conf file modified (as previously discussed):
extlinux-modified.txt (24.0 KB)


Looks like we need further log. All the logs so far didn’t help.

Please add this to your kernel cmdline (exlinux.conf).

console=none keep_bootcon

Also one question here.

How many carrier boards and modules do you have there? Could you share the boot log of your “working” jetson nano 4gb too?

I keep a working 4GB Jetson board for dev. testing and building custom images for our jetbot kits that I keep at my desk.

I was given four boards that the customer sent back. However, I was told that ~8 boards in total were experiencing an issue. I believe two had power issues (seperate topic - green LED would come one breifly and then turn off) and six were getting stuck on the splash screen. (I’ll have to double check with the customer service team to get the exact numbers.) Of the four boards that I have, one had the power issue and three are hanging on the splash screen.

New Logs:


It seems the cause of this issue is revealed with the new log.

It seems you are using nano-2gb sdcard image on a nano 4gb board…

NG log → device tree with p3448-0003 module is nano 2gb.

0.329216] DTS File Name: /dvs/git/dirty/git-master_linux/kernel/kernel-4.9/arch/arm64/boot/dts/…/…/…/…/…/…/hardware/nvidia/platform/t210/batuu/kernel-dts/tegra210-p3448-0003-p3542-0000.dts

Working log → device tree with nano 4gb.

[ 0.328418] DTS File Name: /dvs/git/dirty/git-master_linux/kernel/kernel-4.9/arch/arm64/boot/dts/…/…/…/…/…/…/hardware/nvidia/platform/t210/porg/kernel-dts/tegra210-p3448-0000-p3449-0000-b00.dts

Are you sure that the image on the SD card is the problem? I can double check again, but I am pretty sure that I am using this 4GB image.

I’ll redo the test, but that image worked on the 4GB Jetson Nano (v3) that I normally use. I would assume if I was using a 2GB Jetson image, that it wouldn’t work for either of the 4GB Jetson Nano (v3) boards (working and not working).


Let’s validate this in another way. From the NG board, please do not erase it. Just move the sdcard out from the board. Put it to your host. Check what is inside /boot and /boot/dtb folder on this sdcard. And share me the result.

You can also try the same method on every of the board you hit issue. Share me all the log of these boards so that we can see if they all have same situation.

I would also check where does the device tree get loaded on jp4.5.1 (this is your uboot version)

This is the boot folder from the SD card. I just plugged the SD into another computer with Ubuntu on it, mounted it as a drive, and copied the folder from the SD card. (18.7 MB)

Unfortunately, I am trying to keep my working Jetson Nano in a state where the new firmware hasn’t been flashed, in order to support our legacy custom images for customers. I’ll see if someone at the office has an older v2 board that I can use to check the uboot version.