Jetson Nano booting error after upgrade

I am using Jetson Nano developer kit and I was able to boot normall, but after I try sudo apt-get upgrade, the system did not load up and did not boot. I cannot control anything. I tried to flash image into sd card and still it cant boot normally. What is going on?

Then please re-flash with SDK Manager.

I have re-flashed my Jetson Nano with Jetpack 4.6.1, but when connecting to monitor, it shows that it encountered unrecoverable error during Installation. I tried with Jetpack 4.5.1, still the same with 4.6.1. I tried with headless installation but it request for localhost id and password which I do not know. I am a newbie to Jetson Nano, May I know what can I do next

I mean sometimes re-flashing only the SD card does not fix issues.
Did you do a whole re-flash with SDK Manager?
Please try the latest 4.6.4.

Also dump the serial console log with:

Re-flashing with SDK manager required a Linux-based PC? Can Windows do the flashing ?

You need a Ubuntu 16.04/18.04 PC, and please avoid using virtual machines.

I want to clarify that SD card models of Jetsons still have some memory on the module itself (QSPI memory), and that this is where boot software and the software equivalent of a BIOS reside. If that part is too old a newer SD card release won’t work correctly. You should flash the Jetson itself at least once. After that you can probably get through several SD card updates without any need to flash again.

May I know whether there is anyway to retrieve the data of my old system? Most of my coding works are inside T.T

If you are using the module with an SD card slot, then it should be easy to get the data back with some SD card readers.
If you are using the eMMC one, then try booting into a USB drive:

1 Like

eMMC can be cloned, and the raw clone can be mounted on loopback on the host PC (which you don’t need to do if either (A) it is an SD card model, or if (B) you can boot to alternate media). Still, once you have progress, an eMMC model clone is nice to have as a backup. You can flash with a clone (including with or without first editing it).

I will update my progress on Thursday once I get a laptop and install Ubuntu OS in it, thank you guys for the advices.

When I try to install with SDK manager, the error shows up, is it because I didnt not format my Jetson Nano SD card or is it my host pc problem

Dump the complete log here.
Screenshots are not preferred.

Its ok, after i install full Ubuntu, everything works,

How do I select the booting drive for jetson nano, because I want it to boot with the Sandisk Thumb Drive, not with the SD card reader. Strangely, I only plug in pendrive to the Jetson nano and I am not sure where the 16GB SD Card space from, i wonder its the internal memory of the Jetson Nano

Change the booting device in U-Boot prompt during booting.

Thank you for the advice but it seems like a bit too complicated for me, is it possible to flash into the pendrive or sd card during the flashing process of SDK manager?

Or change /boot/extlinux/extlinux.conf on the SD card/eMMC, and modify

APPEND ${cbootargs} root=/dev/mmcblk0p1


APPEND ${cbootargs} root=/dev/sda1

That way, rootfs will be mounted on your USB drive.
Keep in mind that kernel image and kernel dtb will still be loaded from the SD card/eMMC.

1 Like

I tried to changed but it showed that it is a read-only document and I cannot modify it

You need sudo.

I did it FINALLY! Thank you for your advice, i combine your idea with the YouTube video attached, it finally works!!! Now I can continue with the rest of my project hopefully! Once again thank you guys very much for being so nice to me (newbie 0 knowledge to Jetson Nano)