Jetson nano 2gb dev kit not booting

I have jetson nano 2GB developer kit and I set up the jetson nano and flashed the SD card image on the sandisk microSD 32GB using balena etcher by downloading it from this link, when starting up the jetson by connecting it to Hp monitor using HDMI it just displays the nividia logo forever. I sincerely ask for an advice in this matter.

First of all we should understand the root of the problem. It is SD card problem or it is jetson hardware issue.
Let’s check:

  1. Maybe something went wrong on flashing processes, so try to Reflash the image onto the SD card.
  2. Maybe something is wrong with card, so try using different SD card.

Hope something will work.
And could you tell me from what OS are you flashing? Are flashing on Linux? Windows?

I have tried so many times reflashing the SD card and it is still the same. And the SD card is new and orginal sandisk SD card
Could you send me the image if you have because I have confused which to download since there is many links to download the image and i have tried almost all and nothing changes

Hi. I own Jetson Nano 4GB dev kit.
Here is a link to its image =>
Try flashing that on your sd card. (different software won’t damage your card)

I would once again would recommend to get different sd-card, even smaller.
And could you tell me what OS do you use for flasing sd card? Linux? Windows? iOS?

I flashed the SD card on windows 10

Please move to use sdkmanager to flash your board.

This method is totally different from using sdcard. Sdcard method won’t really flash the software running on your board.

To use sdkm, prepare a native x86 ubuntu 18.04 host.

How can I do that or is there a user guide or video

The website above has the instructions.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.