New Jetson Nano not booting - instead showing "recovery" screen

Got this screen when I tried to boot unboxed Jetson Nano today:


https://twitter.com/idcrook/status/1124475231924473857

I re-flashed the 64GB µSD card (this µSD was known to work fine in another Nano), and same results. I was able to navigate the menu by hooking up a switch to the ‘power button’ in the 2x4-pin header and tried the ‘Boot recovery kernel’, ‘Boot safe mode’ and ‘Forced Recovery’ options. None of them seemed to allow me to boot.

Can someone tell me what is up with my Jetson Nano?

swapped with known good µSD card/image and it boots fine now

The annoying part is the “bad” µSD card worked previously (in a different Jetson Nano Dev Kit) and both that image, and the re-flashed jetbot_image_v0p3p0_63GB.zip were successfully verified by Etcher.app.

So solution appears to be to try a different uSD card or image.

Just a short follow-up. The 64GB µSD card itself was not the problem. I used sdkmanager to install the Jetson OS image + JetPack 4.2 SDK onto same µSD card and now the Jetson Nano/µSD combo that started this topic works fine (boots/run).

So it would point to the 63GB jetbot image (jetbot_image_v0p3p0_63GB.zip) I had downloaded from https://github.com/NVIDIA-AI-IOT/jetbot/wiki/Software-Setup as my issue…

I have the same problem

Can you post the brand, model of the sdcard you are using? I recall reading a thread somewhere else where someone said the card failed in the nano after verification. Perhaps there is an incompatibility. I have seen it happen with some sdcard in raspberry pi.

I have used two 64GB uSD cards with jetbot image. Samsung EVO Select and Sandisk Ultra.

The Samsung fit the 64GB jetbot image. Never have had an issue with.
The Sandisk worked with the non-jetbot Nano image downloaded from NVIDIA website but has not worked with the 63GB jetbot image. And, as I responded above worked fine as well when using sdkmanager running on x86_64 ubuntu 18.04 host to install OS/Jetpack.

All these with exception of SDKMANAGER were imaged using Etcher.app on macOS host.

idcrook,
It looks to me like the QSPI-NOR on your devkit module wasn’t properly flashed with bootloader at factory. When you use SDK Manager, it implicitly flashes QSPI-NOR as well as flashing the SD Card you have inserted into module. That is why it worked after using SDKM.

steffen.teichmann,
You can either use SDK Manager, or download L4T driver package (BSP) and use command line tool to flash QSPI-NOR only. Instructions are in the Quick Start Guide section of L4T Development Guide:
https://docs.nvidia.com/jetson/l4t/index.html

prlawrence,

That makes more sense and supports what I saw. So the 63gb JetBot image is not the problematic then. Hope the production build flow straightens this out. :) glad that SDK MANAGER was able to correct for this in the field.

I have both those brands in both those sizes (Amazon shopper?) and have tested them. I can confirm it’s not the brand at least.

I tried to flash with SDK Manager, but now the jetbot SD won’t even show a screen. Just black but the monitor says ,it has a signal. The Jetson SD boot fine and I can work with it. So like before.

in the process of flashing there were some errors!?

now I flashed the sd card again and the selection menu with continue is back

I had no problems booting my nano with the original image on a 16GB sd card, but got the screen shown at the top went I tried the jetbot 63GB image on a 64GB SanDisk Ultra Plus. I tried a different computer with a different operating system (Linux and Mac) with the same result. I have not been able to discern from the forum a definitive next step.

Hi there!

I have a batch of custom base boards using the Nano Production module. All of the boards in the batch work fine except one which comes up in this recovery menu. (Module is flashed and fully operational). I’ve looked in the documentation but can’t seem to find what conditions need to exist for a module to go into this mode. This particular baseboard does this with all modules, and all modules function fine in the other baseboards, so it’s a problem (shorted pin or such) with this one baseboard.

Any assistance would be appreciated. Thanks!