Factory Reset Jetson Nano 4GB

I am trying to factory reset my Jetson Nano 4GB by flashing the memory card with a new image. But still after flashing the memory card with a new image, the Jestson Nano loads with the old image. It would be really helpful if you could please help me with the steps to reset my Jetson Nano 4GB.

Hi misakib2,

You mentioned a SD card. If the device you’re using is a Jetson nano developer kit, this is unbelievable. After flashing the SD card with an new image, the old image will be completely overwritten.

Maybe you need to talk about which product you’re using.

You should also talk about the difference between “old image” and “new image”, maybe your issue is simply that the QSPI is not updated. For this issue, the use of SDK Manager or L4T package to flash can be solved.


Hello Zz.W,

Thanks for your reply. I bought the Nvidia Jetson Nano from Newsegg (Product Link: NVIDIA JETSON NANO (945-13450-0000-100) Developer Kit - Newegg.com ( I have also attached some photos of the device I have herewith for your kind reference). I set up the Jetson Nano by flashing an SD card with OS. After the setup, I installed some libraries. These installed libraries unexpectedly changed some settings of my Jetson Nano. That’s why I am trying to restart the setup by reflashing the memory card. But every time I reflash the memory card and power on the jetson nano, I can find the libraries in the system that I installed after the setup. I also noticed one peculiar thing. If I even power on the device without a memory card, it perfectly boots up and shows all the files installed.

In this circumstance, it would be helpful if you could please help me in resetting the Nvidia Jetson Nano.

Hi misakib2,

Do you mean that your board can boot up successfully w/o SD card connected?

Could you help to show me the SD slot on your board?

Have you tried to re-flash the board with SDK Manager?

Hello KevinFFF,

Thanks for your email. Yes, I was able to start the device completely without a memory card. Without a memory card, I also saw all the programs I installed myself.

For your reference, I have attached a photo of the device’s memory card slot herewith.

I also tried to re-flash the board with the SDK manager. Though the SDK manager detects the device successfully, SDK Manager does not show me any Target Operating System option. I have attached a screenshot of the Android SDK herewith for your reference

I look forward to your kind help. Thanks.

It seems weird because there’s no SD card slot in our Jetson Nano with eMMC module.
If you have both eMMC and SD card slot, you are using the custom board.

Yes, this is a custom board.

Are you using standalone Ubuntu 18.04 as your host PC for SDK Manager?
Or something like VM/docker/WSL2?

Thanks a lot for your reply. I am really surprised to know that it is a custom board. Newegg (Product Link: NVIDIA JETSON NANO (945-13450-0000-100) Developer Kit - Newegg.com) never mentioned it is a custom board. Can you please tell me what’s happening with the custom board I am using? Why is not flashing memory card replacing the actual OS?

Actually, I am using Ubuntu 22.04 as OS on my laptop (stand-alone) for SDK Manager.

The following is the our Jetson Nano devkit.
Getting Started With Jetson Nano Developer Kit | NVIDIA Developer

Your board looks really like the devkit, but the devkit would not have eMMC and SD slot at the same time, and the SD slot would not be located at that position.
You may use SDK Manager to flash your board if the board design is not much different as the devkit, or you need to request the BSP package from your vendor and flash with script.

For Jetson Nano, it would use JetPack4.x which is supported with Ubuntu16.04 or 18.04.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.