Jetson Nano Won't power on

Hi All,

I’m having an issue with my jetson nano. its a brand new unit and I cant get it to power up.

All I get when I apply power to the board is the green power led. No Video over either port, no network leds and nothing over the uart.

I have tried 2 different Micro SDs that I know to work, 2 reliable micro USB power adapters (5V @ 2.5A) and three different barrel adapters (2 5V@4A and one 5V @ 3A) (and yes I jumpered J48 as needed). and I cannot get anything. I have tried reseating the jetson to its carrier board as well and still nothing.

any further advise on what I could try? or this board dead and need to be RMA?


HI bill,

Have you tried to flash the device with JetPack through SDK Manager?
If not, can you try it to see if can boot the device?


I had same issue what you have at few month ago.
It was solved via changing a cable, Would you trying to replace a display cable(or hdmi, do not use any convertor as like dvi to hdmi) from Jetson to monitor?
Good for you.

Hi Kayccc,

I have not been able to try the SDK Manager. given the current situtation the only x64 linux system I have access to is running 19.04 which wont allow me to select any version. I may be able to access an 18.04 system next time I’m able to be in office (not sure when that will be). Is there any way to make it work with 19.04 or any other suggestions to try?

Thanks for the suggestion, but I have tried 3 different HDMI cables and the only displayport cable I have along with 2 separate monitors. None of these is using any adapter of any kind. I have also tried headless without success.

Hi bill.torode,

The sdkmanager support Ubuntu 16.04/18.06 host machine.
You can download the latest sdkmanager and run it to flash image and install sdk components.
For Nano, you can also use Etcher tool to flash image on sdcard.
Please check the file and document from NVIDIA Download Center. Thanks!

I unfortunately do not have access to a ubuntu 16.04 or 18.04 machine at this time. I have tried to flash the image to several different sd cards that I know work but the nano will not boot from them. I have tried flashing with both etcher and win32 diskimager and verified the download was good by checking its md5 hash.

Hi bill.torode,

Could you try to format your sdcard and using Etcher tool to flash image again?

I tried this again this morning, First formatting the card then using Etcher to flash the card. Still no change

I think you need to dump the serial log from UART.
It might help us check what is going on from software aspect.

The problem is I get nothing over the UART, I even double checked the cable was functional by hooking it up to a raspberry pi. As far as I can tell the only thing I can make this board do is turn on the green power led. I’m not even sure the processor runs as the heatsink never warms

That sounds not good.
Are you able to get one x86 Ubuntu host (16.04 or 18.04) and use sdkmanager to flash the board?(actually it flashes the sd card too)

If even the flash process gets failure, then maybe need to file a RMA.

I do have a 18.04 host machine in the office, however given the current situation I am working from home until further notice, so its hard to judge when I will have access to that machine again, but I’m willing to give it a shot once I am able.