Jetson Nano doesn't start up/ black screen. SDK Manager doesn't detect Nano

Hi all, as titled.

I have a Jetson Nano that I had flashed to Jetpack 4.5.1 in order to test Balena. Now I am trying to flash it back to Jetpack 4.5.1 or at least get it to run Linux/Ubuntu but preparing a SD card via the website instructions didn’t work. There isn’t a logo or anything, my monitor feed backs that there is no HDMI signal.

So I was thinking I could use the SDK Manager to ‘reset’ the board by flashing it again but the SDK Manager doesn’t detect the board at all (No board connected). I have verified that the cable I am using is working and the the board is powered up (Green light).

Is there anything I can do to get it to work?

Same thing for me… i read that the power supply (too weak) might be a problem. But that’s not true for me.

Yea, I use a 5V/4A power adapter. Pretty sure that is enough.

Hi user115869,

Please format your SD card to ext4 and using SDK Manager or SD image to try again.
If still not work, please plug-in tx/rx cable on J50 pins to provide the uart log.
Detail please reference Nano user guide.

Thanks, formatting the sd card to ext4 worked.

1 Like