Jetson nano no display power led on is okay

Please help,
when i turn on my jetson nano
Led = power on
Fan = power on
Display = no display

i tried to connect it on sdk manager but it can only be detected when the jetson is on force recovery mode.
Video is here

1 Like

And is sdkmanager able to flash your board in recovery mode?

You can use the serial console log to tell what is going on.

1 Like

i don’t have that cable.

is this the one i need?
click here

1 Like

Yes.

ok ill buy it, BTW i tried to flash in recovery mode but i still cant proceed.

i jumper the FC recovery pin and ground pin
while the jumper is connected i power on the jetson nano, and the sdk manager was able to detect the jetson nano,
but i cant proceed with the target operation system, i tried to change the sd card with a new one, but still have the same problem with the target OS.

What is “same problem” you are talking about?

Is this your first time using sdkmanager? If so, are you sure you really flash the board correctly?

1 Like
  • yes, i usually flash sd card with etcher, but last time i did the jetson went black screen.

No, we didn’t consider “sdcard + etcher” a really “flash” here.

What sdkmanager does is different from sdcard image. Please describe what happened after sdkmanager flashed the board.

Forget about sdcard image.

1 Like

the problem with sdk manager is that i can’t proceed to step 2.
always stock on the part where i have to select the operation system on step 1.

Sorry for the late response, have you managed to get issue resolved or still need the support? Thanks

1 Like

not yet, im still waiting for the cable that i order.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

Try to use the sceenshot for what you saw. Otherwise I really not sure what problem you have here.

1 Like