Display not working - Jetson Nano Developer Kit 4GB

I went through completing the installation on the first boot. Everything looked great and then I powered things down. Went to turn things back on and the display no longer looks like it is being seen by the board. I don’t get a “No Signal” error. Monitor doesn’t do anything. I also tested it with another monitor and it got No Signal, but would not do anything else. The green light on the board is lit up.

I was using a 7" Rasberry Pi tocuhscreen monitor initially which gets power via USB, but I also tested with a regular monitor with a typical power cord. Both via HDMI.

Any guidance is greatly appreciated.

Which version of Jetpack have you flashed ?
Did you flash using SDKmanager ?

I just downloaded the image from the Get Started site. I can’t get any display to be recognized/detected. I tested my initial display on another computer to confirm it worked. And I tried a completely different display. I also formatted the SD again and re-flashed the Developer Kit SD image. The green light on the board comes on when I power it on, but I can’t get any display to show.

This was a sealed box, never before used. Again, I was initially able to complete the setup. Finished the setup and shut things down. Haven’t been able to get a display to work ever since.

I used SD Card Formatter to format the SD card and Balena Etcher to flash the image. Following instructions per the Nvidia Jetson site.

Hi Michael,

by a completely different display do you mean one that was not touchscreen and HDMI ? have you also tried with the display port ? are you able to connect to it using serial or ssh ?

Could you also try flashing using SDKmanager ?

Hi Neel,

Yes. I tried a completely different display than the original touchscreen HDMI display and I tried to connect to another monitor via Displayport this weekend. I still get No Signal as if the display is not at all detected. I have the green power light on the board still. I also have swapped out the power supply.

I am not able to access it at all because it was only ever on once. I more or less powered it up once after 15 minutes of taking it out of the box. I did the initial setup fine. Basically I got through the Setup and First Boot step on the NVIDIA Get Started site and logged in. And then powered it off because I had to leave. And I have never been able to connect a display or see into it since. I have reformatted and re-flashed the SD card a few times.

I am not able to use a display with either HDMI or Displayport. Is there any other way I could possibly access the Nano via IP if it is powered on? It would be a fresh install again at this point.

If your host supports ncm, then your host side shall have a IP and device side will be when micro usb cable is connected between your host and device after device is correctly booting into system.

Or there would be /dev/ttyACM0 interface shown on your host under same situation.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.