Jetson Nano 2GB failing to bootup or show anything

My Jetson Nano 2GB is failing to bootup, I have tried everything with all the required materials from the getting started page.

The only thing I see is a green LED light on, where as when I plug in any USB fails to detect or Ethernet connection fails to show any LED on. Not sure why. Display is black, no sign of anything!

I have re-written and flashed several microSD cards multiple times of all the required version.

The only thing left is to debug the console. In meantime wanted to know if any one has gone through similar experience ?

I’m in India and bought the Jetson from rptech india trusted partner of Nvidia. I have raised my concerns with them.

Hi,

Could you try to use sdkmanger and see if it can flash your board or not?

Also, dump the serial console log if possible.

    • Serial console log I shall in a couple of days as I have ordered the TTL to USB cable.
    • I shall try to flash it via virtual box with linux host in it. I do have a mac os catalina.

Sorry, virtual machine is not guaranteed. Please use a native host.

ok. then I will dual boot my macbook and try tonight…

my device is not even being detected by my mac also in the sdk manager no board connected. Also verified via terminal.

Do you put device into recovery mode?

No, I will do that and flash it. But here you go the problems seems to be regarding GPT partitioning.

Serial Console LOG

[0000.131] Processing in cold boot mode Bootloader 2                         
[0000.135] A02 Bootrom Patch rev = 1023                                      
[0000.139] Power-up reason: pmc por                                          
[0000.142] No Battery Present                                                
[0000.145] pmic max77620 reset reason   
[0000.148] pmic max77620 NVERC : 0x41   
[0000.151] RamCode = 1                  
[0000.154] Platform has DDR4 type RAM   
[0000.157] max77620 disabling SD1 Remote Sense
[0000.161] Setting DDR voltage to 1125mv
[0000.165] Serial Number of Pmic Max77663: 0x1d1ef8
[0000.173] Entering ramdump check
[0000.176] Get RamDumpCarveOut = 0x0
[0000.179] RamDumpCarveOut=0x0,  RamDumperFlag=0xe59ff3f8                       
[0000.184] Last reboot was clean, booting normally!                             
[0000.189] Sdram initialization is successful                                   
[0000.193] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000            
[0000.199] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000                 
[0000.205] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000              
[0000.211] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000                
[0000.216] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000                
[0000.222] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000                
[0000.228] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000                
[0000.234] GSC3 Carveout Base=0x00000000bf300000 Size=0x00d00000                
[0000.250] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000             
[0000.256] Platform-DebugCarveout: 0                                            
[0000.259] Nck Carveout Base=0x00000000ff080000 Size=0x00200000                 
[0000.265] Non secure mode, and RB not enabled.                                 
[0000.270] Read GPT from (4:0)                                                  
[0000.458] Csd NumOfBlocks=124735488                                            
[0000.463] Set High speed to 1                                                  
[0000.467] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWai 
[0000.477] Command complete wait failed with error 0x3 Interrupt 0x18001        
[0000.483] Number of retries left 4                                             
[0000.497] Invalid GPT Partition                                                
[0000.500] Read PT from (2:0)                                                   
[0000.515] Using BFS PT to query partitions                                     
[0000.519] PT: Partition TBC NOT found !                                        
[0000.523] Warning: Find Partition via PT Failed                                
[0000.527] failed to load NvTbootTbootCpu from (4:0)                            
[0000.532] re-load NvTbootTbootCpu from (2:0)                                   
[0000.536] Read GPT from (4:0)                                                  
[0000.539] Invalid GPT Partition                                                
[0000.542] PT: Partition TBC NOT found !                                        
[0000.546] Warning: Find Partition via PT Failed                                
[0000.550] Read GPT from (4:0)                                                  
[0000.563] Invalid GPT Partition                                                
[0000.566] PT: Partition TBC NOT found !                                        
[0000.570] Warning: Find Partition via PT Failed                                
[0000.574] Error is 1   

GDISK

[sudo] password for mohan: 
GPT fdisk (gdisk) version 1.0.5

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.

Command (? for help): v

Problem: The secondary header's self-pointer indicates that it doesn't reside
at the end of the disk. If you've added a disk to a RAID array, use the 'e'
option on the experts' menu to adjust the secondary header's and partition
table's locations.

Identified 1 problems!

dmesg --follow

[13896.981843] GPT:27871231 != 124735487
[13896.981844] GPT:Alternate GPT header not at the end of the disk.
[13896.981846] GPT:27871231 != 124735487
[13896.981846] GPT: Use GNU Parted to correct GPT errors.
[13896.981869]  sdb: sdb1 sdb2 sdb3 sdb4 sdb5 sdb6 sdb7 sdb8 sdb9 sdb10 sdb11 sdb12 sdb13 sdb14
[13897.605872] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)

This seems to be relating to this Nano failed to boot

  • I ll have to look into it, I tried different fixes using gdisk to fix the table etc nothing works.
  • Flashed the image onto the sd card using both dd and etcher on linux.

Just want to remind that… sdkmanager has nothing to do with sdcard image, which you use dd/etcher to flash.

If you cannot understand that, please tell me.

I notice more and more users now don’t understand what sdkmanager is doing…

sure @WayneWWW shall keep you updated. I just ordered jumper with switch for flashing.

1 Like

Hi Wayne,

I tried to flash my nano after getting hold of a linux machine and other components required.

  • put the jetson nano 2Gb on recovery mode.
  • confirmed the above by lsusb command to detect it.
  • tried to flash it using the sdk manager, I got the below error while flashing.
00:34:02 ERROR: Flash Jetson Nano 2GB (Devkit): Board ID(3448) version(400)
00:34:02 ERROR: Flash Jetson Nano 2GB (Devkit): 1+0 records in
00:42:12 ERROR: Flash Jetson Nano 2GB (Devkit): [error]: : [exec_command]: /bin/bash -c /tmp/tmp_NV_L4T_FLASH_NANO_2GB_DEVKIT_WITH_OS_IMAGE_COMP.sh; [error]: 1+0 records in
00:42:12 ERROR: Flash Jetson Nano 2GB (Devkit): command terminated with error
00:57:43 ERROR: Flash Jetson Nano 2GB (Devkit): [error]: : [exec_command]: /bin/bash -c /tmp/tmp_NV_L4T_FLASH_NANO_2GB_DEVKIT_WITH_OS_IMAGE_COMP.sh; [error]:
00:57:43 ERROR: Flash Jetson Nano 2GB (Devkit): command terminated with error
  • this error popped up while flashing the OS onto the jetson nano.

also this is same detailed log for the nano…

Info: exec_command [host]:
**********************
#!/bin/bash
set -e
set -e
if [ -e  ./bootloader/system.img ]; then
    echo sudo ./nvautoflash.sh --no-systemimg
    sudo ./nvautoflash.sh --no-systemimg
else
    echo sudo ./nvautoflash.sh
    sudo ./nvautoflash.sh
fi
sleep 20
**********************
Info: exec_command: /tmp/tmp_NV_L4T_FLASH_NANO_2GB_DEVKIT_WITH_OS_IMAGE_COMP.sh
sudo ./nvautoflash.sh
*** Checking ONLINE mode ... OK.
*** Checking target board connection ... 1 connections found.
*** Reading ECID ... FUSELEVEL=fuselevel_nofuse hwchipid=0x00 bootauth=
*** Error: Unsupported Tegra SoC ID 0x00 found.
Terminating..
Info: [ Component Install Finished with Error ]
Info: [host] [ 0.00 B released. Disk Avail: 10.17 GB ]
Info: [ NV_L4T_FLASH_NANO_2GB_DEVKIT_WITH_OS_IMAGE_COMP Install took 0s ]
Error: [error]: : [exec_command]: /bin/bash -c /tmp/tmp_NV_L4T_FLASH_NANO_2GB_DEVKIT_WITH_OS_IMAGE_COMP.sh; [error]: 

I have the some problem only on 4gb version …

The issue was with the board, did the RMA process and confirmed it with the authorized vendor of Nvidia in India (rptechindia). They are now in the process of replacing the board.

I would try the same since it is not flashing. Will mark this as the solution temporarily. Until @WayneWWW as any other resolution for this.