Can't boot up Jetson Nano after flashing new image on SD card

BTW, I am not sure the method you put the board into recovery mode is correct or not.

Please plug in the jumper when no power cable is connected. Then, do not remove the jumper, plug in the power cable.

Hi @WayneWWW,
I currently don’t have another Jetson device to test.
My Ubuntu is not running on VM.
Here I just made a video on what I did (I can’t upload the video here since the size limit is 100m): IMG_1891.mp4 - Google Drive

I noticed that the USB cable is not the NVIDIA cable. Many “charger” cables have insufficient quality to function correctly, although in most such cases lsusb shows the device and only fails after flash starts. Do you have any different cables (different models) which you can try? Possibly the cable is not the cause, but if it is the cable and you go through the effort to swap units, then it’ll just appear as failed again.

Thanks! @linuxdev

I switched the micro usb cable to another one (the one i used for my xbox handler) and now JDK Manager can detect my Nano! Great progress!

But now I faced another issue: the image flashing hung at 99% and its been hours. There is no error in the terminal!

Im wondering what did wrong here 🤔

Please share the uart log when this error happened.

Also, you can try it multiple times and see if it always got stuck.

I’ve tried three times already, still has the hanging issue. There is no error message from the SDK manager terminal, let me see if i can get the uart log you mentioned above.

BTW, if you really want to share helpful info, there is a export logs button on sdkm after you pause it.

When i hit the pause button, it says completing current task. Looks like it wont pause until the flashing finishes.

How about you directly try to use This could save time in dealing with this GUI stuff.

hi @WayneWWW , i would like to try
Can you give me more information on using

There should be a Linux_for_Tegra folder in your ~/nvidia downloaded by your sdkmanager. is under this folder. Please try to

  1. Put your board into recovery mode

  2. Generally the flash command is
    $ sudo ./ [options] [board] [rootdev]

if you want to flash jetson-nano-devkit with sdcard as rootdev, the command will be

sudo ./ jetson-nano-devkit mmcblk0p1.

The board list is over here.

hi @WayneWWW,
When i run the above command, i get this error:

I think this only indicates the flash is not stable.
Then please share the uart log. What happened in will also happen in SDKM GUI.

Hi @WayneWWW , i dont have a usb to TTL cable for uart. Let me place an order online to buy one.

Glad to see progress. A real shot in dark, maybe try uninstalling the wifi card and try flashing again.

I have no reason to suspect that this would help except it removes one more variable.

Thanks @Dingo_aus ,
Let me try again without to the wifi card.
By the way, im still waiting for the cable i ordered online to export uart log.

Hi guys, I have my cable delivered for exporting the uart log. I’ve followed the tutorial to connect Nano to my Ubuntu. There is no log showing up from the terminal, and now my Nano couldn’t even enter discovery mode any more.

I’ve spent around 2 hours every day for almost two weeks, and it’s frustrating not solving the problem. I think my knowledge is not adequate to work on Nano. I probably won’t work on Nano for a period of time until I’m capable of embedded system.

Even though I couldn’t solve the issue, I really appreciate your help along the way!


You could try to just dump the log without recovery mode, make sure the uart can dump the log first…

Also, it is your own decision, so if you don’t want to try, then it is also okay.

Thanks @WayneWWW , I decided not to invest more time on this issue.
Thanks again for your informative help and I’ve really learnt a lot! And you can close this ticket off if it’s needed.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.