Jetson Nano stopped working

Hi
I have been using my jetson nano quite happily for a few weeks. Today I downloaded and installed the jetbot image. I started to have problems with the wifi card not being recognised. I swapped back to my standard image and again the wifi was no longer detected. I then stared having problems booting the device.
I flashed a new copy of the standard install. The system starts to boot, you see the nvidia logo and then the display goes blank.
Any ideas.
Thanks
Mike

Just a quick addition. On my original setup I installed x2go.
I have just tried booting from that SD card still same no HDMI output. But I have tried to login to my system through x2go and I can my desktop. So I am wondering if the PCi bus is damaged. Does any know if the HDMI port would be affected. As I said previously I get not HDMI output after the initial NVIDIA logo

I would recommend checking serial console since video failing is a long way off from boot failure. This is similar for a Nano and a TX2, just different connector pins:
http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

It is highly unlikely PCIe is involved. Video on a Jetson is integrated directly to the memory controller.

Thanks for the info. As mentioned I have now proved that it is definitly fully booting, as I can login remotely via x2go. But I am not getting any HDMI output to my main screen after the initial logo. Not sure where to look for problems.

This was for the TX2, but should also apply to Nano:
https://elinux.org/Jetson_TX2/r28_Display_debug

Do note that if the monitor in question is using an HDMI adapter and is not native HDMI, then details are important. If you can post the output from:

sudo -s
cat `find /sys -name 'edid'`
exit

The out is NO EDID

Hi
Just followed the link you gave. Thanks. However, I have two directories /sys/kernel/debug/tegradc.0/mode
and /sys/kernel/debug/tegradc.1/mode

If I try and cat tegradc.0/mode the console hangs. But I do see content from tegradc.1

I am beginning to feel that the board is faulty.
Trying to cat tegradc.0/stats also hangs the console.
If I try and do an apt-get upgrade is fails on nfs-common and hangs
If I try to reboot from the console or shutdown the console also hangs.

OK here is some strange activity worth investigating. Anyone have any clues.
This morning I received my usb to ttl adapter. Plugged it into the serial connectors on the jetson.
Baud 115200 8n no handshake. Nothing appeared on the terminal when I booted the jetson with hdmi unplugged.
Rebooted jetson with hdmi cable attached, got a few graphic blocks printed on the serial terminal emulator and suddenly output to the hdmi screen. When jetson boots I get a error message on screen stating System Problem detected. If I select Report problem and look at details I get com.ubuntu.apport.apport-gtk-root

I also get an internal error message nvphsd crashed with SIGSEGV in ipc_unregister()

Looking at the display settings its now not identifing the display correctely it shows NVD 40" and gets a max resolution of 1280x720

If I disconnect the serial link and reboot the HDMI stops working.

So long story short I can only get my HDMI output if I have the serial console plugged in.

In terms of video the lack of EDID means the monitor failed to communicate its configuration to the Nano and the Nano has no way to know what is connected. No automatic configuration is possible, although in some cases a fallback mode might work. VGA adapters will cause this, but if using purely HDMI without any special adapter this should probably have found EDID. Is there anything unusual about the monitor?

You may have found both tegradc.0 and tegradc.1 due to both a real desktop and a virtual desktop existing (tegradc is Tegra Display Controller).

The serial console should be independent of HDMI, so having serial work with HDMI and not work without HDMI is quite unusual. The error you are getting though does indicate boot is working and perhaps it is something just in the GUI going bad. HDMI is hot plug, and so unplugging/replugging can sometimes fix something which just requires detecting the monitor. The lack of EDID though tends to imply the monitor is not detected. Can you post a URL to the monitor, hopefully with specs (or the ability to search for the specs)?

Thanks.
The Nano has been working quite happily on this monitor since I bought it. It has only stopped working in the past few days. But I will try another monitor tonight.
Regarding the serial problem, I think you miss understood.
Basically I don’t gey any out from the serial port itself. But when the serial adapter is connected the HDMI screen works, but when I disconnect the serial adapter HDMI stops after the nvidia logo. Its reproducable and I have tried flashing a new SD and get the same results. Bit of a puzzle.

I’m not sure why the presence of the serial debug would change the HDMI. The serial port is not something with any form of “detect”, and thus it runs the same regardless of whether anything is connected or not. If i2c were involved, then I might suspect the power bus was turning on because of something detected (the HDMI EDID is i2c), but serial UART should be 100% independent. This is quite odd.

Even so, there is very little which can be stated unless the EDID is present. If your next monitor has EDID present (even if the monitor doesn’t otherwise work), then progress will have been made. If there is a fault which causes EDID to not read even when it should, then this is probably a hardware failure of either the HDMI cable or the Nano. If a new monitor shows EDID, then that whole chain of EDID support will be demonstrated as working (or at least not outright failure).

Hi
I have tried another monitor and a new cable still same results. and edid say NO EDID
As the serial console does not appear to work either then i think there must be some sort of hardware fault on the Jetson.

It is probably time to RMA. What you’ve tested so far does indicate HDMI should at least get the EDID, but this is missing. Any normal HDMI monitor should provide this even if video doesn’t like the EDID. Having the second monitor and cable do the same thing is good evidence of hardware failure.

There is some RMA information near the top of this:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/

Thanks for all the info I started the RMA process this afternoon.

hello, I have a problem displaying the Jetson Nano display output to the monitor, I initially tried to use a monitor with the same VGA display input conversion to HDMI, at first the boot went smoothly without any problems until the NVIDIA logo appeared and I was able to log in to user registration, but when registration is complete and try to enter the desktop page my computer suddenly turns off, where the green light on the computer also dies, and on the monitor screen can not display anything there is only the writing no signal, I try to turn on my computer but unsuccessfully, I tried to reinstall my sd card again and tried the manual installation step but it still didn’t work. Do friends have a solution to my problem? I beg for your help, because this concerns my university graduation. Thank you

You could start a new thread, but lots of copies of the same topic are harder to answer. Partial answer here:
https://devtalk.nvidia.com/default/topic/1050761/jetson-nano/can-t-get-my-jetson-nano-to-display-on-dell-monitor/post/5420771/#5420771