Jetson Nano powering up with uUSB, but not with the barrel jack (even w/ J48 shorted)

Hi Nvidia and fellow makers!

I was able to successfully power-up Nano with the micro USB and even install stuff on it, but when I tried to power it with the barrel jack (yes, I had shorted the J48 pins with a jumper), I saw is no sign of life on the board. I am using an adjustable desktop power supply (5A max) still wasn’t able to get it working.

Any clues on where I might be missing something?

Hi, i think first you need to check if there is real 5V input to board on cap C308, and if there is 5V output after DC/DC (U58) on cap C315.

Hi,

I Did the same and would not power up with desktop power supply, tried a 5v 4A switching power supply and it worked.

this concerns me a little, if it’s that fussy, will the Nano run off a battery?

Hope this helps.

Hi @Trumany,

I couldn’t find C308, but I measured the voltage across C315 to be only around 1.42 V :(. I did measure the output across the female jack, which was 5V. I guess the DC/DC convertor is to be blamed for the problem.

The only way I power it up (for highest performance) is by using the expansion headers, which is a bit inconvenient. I would really like it to be powered by a DC barrel jack.

Do you know if it is possible to replace the board if its a manufacturing defect? It’s been a week since it arrived. I had ordered it from the Nvidia website.

You can run RMA process if the DC/DC broken: https://developer.nvidia.com/embedded/faq#rma-process