Jetson Nano Barrel Jack power not working

I tried to use barrel jack power connector and used a jumper with 5A 5V charge, im not getting any HDMI output but the fans are running

Any Ideas thanks

1 Like

“connect the J48 Power Select Header pins to disable power supply via Micro-USB and enable 5V⎓4A via the J25 power jack.”

from JETSON NANO DEVELOPER KIT USER GUIDE

1 Like

Yes, I did and fans are running but no HDMI output

Im using a 5A adapter but technically jetson nano would pull 4A so shouldn’t be a problem

1 Like

you can test the 5V supply’s voltage, jetson nano won’t boot if it is under 4.75V

You should also try to ping the Jetson since video is a really bad way to determine a unit hasn’t booted. Quite often lack of video configuration is confused with a failed boot. One example would be using an HDMI-to-VGA adapter doesn’t work, and people assume the boot failed.

Using the jumper and 5V / 10A power supply, the barrel jack worked fine once. Ever since then, I cannot get the barrel jack to work, only the Micro-USB. Is there a fuse, breaker reset or other way to get the barrel jack working again? Should I return it as not meeting spec? I’ve had it less than a month. Thanks!

Sorry for late reply. Is this issue resolved?

No, it is not resolved. I know to use the jumper when attempting to use the barrel jack for higher power. Only microUSB (without jumper) is working. I have not tried high power mode to PCB pins directly (with jumper, of course). Should I return it for a refund or replacement?

I have a 5V 4A power supply, it’s not powering from barrel jack, only micro-USB. Is there some software or hardware setting hidden in the docs?

You also must jumper J48.

Nvidia might consider putting this on a sticker covering the barrel jack on new releases. I know it’s in the documentation, but people miss things, and this seems to be a fairly frequent miss.

I also use 5V 4A adapter and jumped to J48 but still can’t boot normally, this screen appears.

https://photos.app.goo.gl/7GV9L8vRta7FfCvF6

I have tried every option and it doesn’t work.

Hi, did you follow the steps in user guide to setup dev kit?

In summary:
• You need a 16 GB or larger UHS-1 microSD card, HDMI or DP monitor, USB
keyboard and mouse, and 5V⎓2A Micro-USB power supply.
• Download the image and write it to the microSD card.
• Insert the microSD card into the slot under the Jetson Nano module, then attach the
display, keyboard, mouse, and Ethernet cable or wireless networking adapter.
• Connect the Micro-USB power supply. The developer kit powers on automatically.

Is there any log info output from UART console (J44)?

I’m having the same problem as the original author. I jumpered J48 with more than enough voltage and amps, but it won’t turn on.

Interestingly, if I de-jumper, the microUSB will only work with a wall adapter but not a battery; that is, until I plug in the barrel jack power. Then it works sometimes.

This person believes the power supply must have very low output impedance: https://www.youtube.com/watch?v=hV6Znadax-Q

Using a 5V 10A regulated switching supply from EBAY:
https://www.ebay.com/itm/5V-12V-3A-6A-10A-30A-Regulated-Switching-Power-Supply-for-LED-Strip-light/283460604634?ssPageName=STRK%3AMEBIDX%3AIT&var=584517553594&_trksid=p2060353.m2749.l2649

I was able to boot the Nano, BUT ONLY if I tweeked the output voltage to 5.3V or higher (running at 5.35 is stable). This voltage has been verified with two different voltmeters.

Also I am using 30cm of 20AWG wires from the supply terminals to the barrel jack… which should give a voltage drop of well less than 0.1V.

Is there excessive voltage drop between the barrel jack input and the regulators on board over the traces?

Hi Fizprof,

My guess is that there is likely a voltage drop, because the Nano only turns off when I run a large ROS launch file. I’m not sure how to test the voltage; I haven’t studied much of electronics, unfortunately, but I can try if there are instructions.

My current plan is to try this battery: https://www.amazon.com/gp/product/B07H6LB4J4

It is listed here so it’s probably tested: https://elinux.org/Jetson_Nano

Are you powering both the barrel jack and microUSB; or can you get it working with just the barrel jack? If just with the barrel jack, do you have any recommendations to get it powered with the 4A but with a wireless solution?

It’s more likely there’s some reverse connection protection diode, which could drop between 0.3V and 0.8V depending on type. (Presumably not 0.8V …)
What do you get when you measure the 5V rail on the pins 4 and 6 on the 40-pin GPIO header, when powering from barrel jack?

Hi Void12987:

I am powering the Nano with only the barrel jack

If you use a battery bank I would suggest you just go through the USB port. You should make sure that the output voltage is at least 5.2V – I doubt it would be adjustable though.

I am not sure what you mean by “4A” – do you mean the barrel jack? the power supply I got on EBAY works well with this assuming the voltage is tweeked up by at least 0.3V

I have no recommendations for wireless – I don’t know anything about that area…

Hi Snarky:

I get about 5.18V between pins 4 and 6 on J41 when powering from the barrel jack (at 5.35V)

@snarky,

Currently, I can’t power with only the barrel jack because I don’t have a compatible power source. I’m using a Turnigy 11.1V 20-30C battery. If I power the microUSB with an iPhone battery and the barrel jack with the Turnigy, I get 5.04V between pins 4 and 6. When measuring this, the green light turned off with this reading. Do you have a recommendation for enough volts and current for a wireless solution?

@fizprof,

I can’t go through the microUSB port because it gives a max current of 2A; and for my robotics applications, I will need the 4A that is outputted from the barrel jack. Currently, I can’t power the Nano with just a Turnigy 11.1V 20-30C battery, even when J48 is jumpered. Is this because of a current or voltage issue?