Barrel jack worked once, then no more

Using the jumper and 5V / 10A power supply, the barrel jack worked fine once. Ever since then, I cannot get the barrel jack to work, only the Micro-USB. Is there a fuse, breaker reset or other way to get the barrel jack working again? Should I return it as not meeting spec? I’ve had it less than a month. Thanks!

Have you checked the power supply? Check the voltage with a multimeter, and also (Amperes) the current it supplies to your Jetson Nano. You just need some experience in electronics.

Also, you can try power the Jatson Nano via GPIO.

See here:
https://devtalk.nvidia.com/default/topic/1052583/jetson-nano/can-i-power-jetson-nano-through-the-40-pin-gpio-header-/

Hi derekdecker,

It looks like something broken. You need to follow instruction of @Glocke to check the voltage and current first.

Derekdecker, if you don’t have experience with electronics, see any tutorial in Youtube.

Search for :

1)“measure voltage with multimeter”

2)“mesaure current with multimeter”

(The procedure for current is diferent, be care!)

Hi Glocke, I teach electrical engineering labs and lectures and have decades experience with electronics. My power supply gives the voltage and current but I also use multimeters and a scope for monitoring. I will try the header next

I tried the header, connecting pins 2 and 4 to 5V and pins 6 and 39 to GND. With J48 jumpered, the onboard green light came on and nVidia logo appeared pulling about 0.33A, as if it would boot up normally. Then it died. Removing the 5V and GND and reapplying did nothing. The microUSB (J48 not jumpered) still allows it to boot up just fine. I cannot get to high power mode and would like a replacement, having documented these failures within 30 days from purchase. How do I get a replacement or get reimbursed for my flawed Nano? NewEgg said nVidia has to reimburse me.

Maybe you mean the RMA?
https://developer.nvidia.com/embedded/faq#rma-process

Good news! My Nano barrel jack is working again. Per another thread, I ordered proper jumper clips. Before I was using wires with female pin connectors (too much resistance?). Also, I switched over to a heavy power supply which is probably quieter (less noise). Not sure exactly which thing solved the problem.