Is my USB power supply broken or my Jetson Nano broken?


I was working a few weeks back on my Jetson Nano, using the micro USB port for power supply. The adapter for the power supply had 5V, 2A specifications and so Jetson Nano worked without any issue. I took a break for around 2 weeks where I did not operate my board at all and came back to see that suddenly the same power supply is not able to power up my board.

I checked the usual suspects. Firstly, there is no jumper present on the J48 pin. Next, I tried replacing my power adapter with a different one with the same capacity, but to no avail, which means the issue is not in the adapter itself. If the power supply is not enough for Nano, even then it should at least power up and show the green light on the board right? Also, nothing has changed in the last 2 weeks and so the same power supply should work right?

I am currently ordering a jumper and a 5V, 4A barrel power supply in order to see if the alternate power supply option can work. Mainly, I want to understand what could have gone wrong to cause this? Is it possible that somehow the micro USB power circuit got broken, but it has not affected the board itself and there is some hope if I switch to a different form of power supply, or it must be some internal error in the board itself and changing the power supply is not really going to matter? Also, since the board is not even powering up, what exactly can I do to further investigate this?

Thank You

You’d have to try your other power supply to be certain, but a 2A supply is a bit marginal. I would not be surprised if both the Nano and the power supply are perfectly good and operating normally, but the power supply could stop working anyway due to how stable it must be at the moment of power on.

Even if something simple like the local temperature changes it is possible the power supply is no longer in spec. The barrel connector is a much better way to power the system anyway since it is able to handle higher current (powering a USB2 device from a host has specified limits, the barrel connector does not have those limits).

Sometimes it is not about the total power delivery, but instead about the quality of regulation right at the moment of powering on. Very high current availability might still fail unless the voltage remains absolutely stable right at the moment of power up. Even marginal supplies may work if they have a high value capacitor right at the connector to the Nano.

1 Like

Hi @linuxdev ,

The board is still not powering up, even with a 5V 4A barrel power connector. I used a jumper on the J48 pin, so that’s not the issue.

While inspecting the board, I noticed that two pins on the J41 extension are slightly bent. Pin number 17(3V3) and 19. Could this be a reason for my board not working? What exactly is the function of those 2 pins?

Also, if that is in fact the reason for my board not working, is there any workaround this issue on my own? Or do I need to get my board replaced?

I am actually on a deadline and need to do some quick experiments on the device, that’s why I am looking for a solution which can allow me to run the device for a few days as soon as possible, and then maybe I can send it for repair later.

Finally, how does one debug what could be wrong with the board when it is not even powering up? What do I need to do next?

Thank You again.

Were they shorted together? As you mentioned, pin 17 is 3.3V. Pin 19 is an SPI pin. I doubt a short would cause a hardware failure, but it could. If the two were not shorted, then the bent pin would do no harm. You can always use a meter and see if pin 17 is still 3.3V to at least test that.

Does your use include needing SPI? If so, then this could be an issue, but it is unlikely to cause power up to fail.

I have no way to help you debug anything specific since it is apparently a hardware issue. However, in a very large majority of cases where something like this is wrong, then it is a carrier board hardware error, and the module would be fine. In theory you could just move the module to a new carrier board if that is the issue. You cannot separately purchase the dev kit carrier board, but you could still interchange them if you have two dev kits.

Be sure to note that earlier carrier boards model a02 are not compatible with the b01 carrier boards (everything even semi-recent is the b01 model). Do you have another carrier board to test with?

No they were not shorted together. Just slightly bent. Not sure what does it mean when you say whether my use include needing SPI. I don’t need any external connections from the board. All I do is insert an SD card, connect it to the LAN, and then power it up so that I can access it through terminal on my laptop.

Unfortunately no. I guess I will have to send it back to see if it can be repaired or exchanged, or just buy a new board which might actually be quicker. Thank you for help though.

One last question, is there any way of simulating a Jetson Nano environment online without actually buying the board and waiting for it to arrive? For example, you can either buy a GPU, or use cloud services to actually their GPU. Is there any such possibilities of Jetson Nano that you are aware of?

There is a chance the board is actually failing due to the short, but I could not say for sure. My comments on SPI are because of the SPI pin being one of those involved in the short.

I do not know how to emulate the environment. That tends to be something you hear about more for a desktop PC. There is some possibility of using QEMU for CPU emulation, but I have not heard of any such thing working with a full Jetson (e.g., I have not heard of anyone getting CUDA development work within QEMU).

Luckily, I was able to borrow a Jetson Nano board from a friend of mine, and so I can do all the short term experiments I need to do before I send my board back for repair/replacement.

Thanks a lot. Your responses were very helpful.