No power-on from Micro USB after working fine

Hello,

I have been working on the Jetson Nano B01 for a few days with this SparkFun JetBot (https://www.sparkfun.com/products/16417) and this stereo camera (https://www.waveshare.com/wiki/IMX219-83_Stereo_Camera).
I am also running the SparkFun JetBot image. I set the power mode to 5W, because I want to use the 10000mAh power bank as mobile power supply. The power supply was perfectly fine, even when I had WiFi-adapter, mouse, keyboard and a DisplayPort monitor connected. I did some testing with the cameras connected to CSI and everything worked.

I disconnected everything except the cameras and wanted to connect with JupyterLab. This also worked. I tried the JetBot example code before with the camera delivered by the SparkFun JetBot and now just wanted to try if it works with the other camera.
At some point the power supply was not given anymore and the Jetson does not power on with Micro USB, also the green LED does not light up and I don’t get any serial output.

I tried it with a different power bank and also some adapters and cables that worked before and fully charged the power bank with which it was working before. But I still get no response from the Nano, also no LED.To check if it is software related, I measured the voltage at the 5V Pin, which should offer this voltage regardless if the Jetson is booting or not as far as I understood, and get nothing with all of the tried out power supplies.

However, I can get the Jetson running normally with the barrel jack and the LED is on and I get serial output. I also measure the expected voltage at the 5V Pin of the Nano.
I also put the jumper on J48 only if I want to supply with the barrel jack.
But given by my use case of a mobile robot I must use the Micro USB power bank as a power supply.

So I assume something is wrong with the hardware only considering the Micro USB.
My question is if there is a fuse or something that could be broken and how would you further approach this problem, because I don’t know what else I can check.

Thanks

Hi,

If this is Nano b01 devkit carrier board, then maybe you can directly RMA this board and get a new one.

It depends on you. If you think power barrel jack can still make your work done and don’t want to RMA this. It is fine.

Hi there, I recently purchased Jetbot Kit from Sparkfun and I got exactly what you faced. I tried to test several examples through Jupyternotebook and shutdown properly through the command line. Then, Jetson Nano is not booting up through a USB power bank/battery. If I switched from the USB to a barrel jack with a J48 jumper, it works fine. I have tried to use USB cable for Raspberry Pi, which gives 5V/2.5A (not a 5A/2A) but the same thing. If I removed USB WiFi from the jetson nano, it will boot up.
Then, switching from USB power cable to the power bank, it won’t boot up even without USB wifi dongle. So, definitely, Jetson Nano has a power distribution issue through USB connector.
It is weird it booted up at the first time with the power bank that makes me so confused. So Jetbot needs a updated battery information.