Jetson Nano spontaneous power off, zero sized image capture and connection failure issues

Hi, I did the “Getting Started with AI on Jetson Nano” course. I found some strange issues and I wonder if anyone has this too? For the accessories of the course I bought the Nano-DLI-kit to make sure I had the right things. During the course the Raspberry PI camera and a Logitech USB camera were physically connected but most of the time I used the USB camera in the Jupyter notebook.

  1. During the course the Jetson Nano regularly suddenly spontaneously powered off. Is there an autopower off function on this board or is this known feature? The power adapter is from Mean Well GST25B05-P1J output 5V, 4A 20W max.

  2. During capturing of the images some jpgs were zero sized. This caused the training to hang. To solve it I removed these files and add some new ones. Is this known?

  3. I had also regularly a broken connection. The only way was to turn the power of and on and reboot and connect again. And run the cells and do training again.

Cheers,
Dave

Hi,

1. Power off is usually related to the power starvation.
Please check this topic for the recommendation of power adapter.
https://devtalk.nvidia.com/default/topic/1048640/jetson-nano/power-supply-considerations-for-jetson-nano-developer-kit/

Or you can switch to 5W mode to see if helps:

sudo nvpmodel -m 1

Guess that the question 2) and 3) are related to the issue 1).
Would you mind to check the first issue first?

Thanks.

In the 5W mode issue 1 also happened but only it takes longer. Issues 2 and 3 did not occur anymore but the Jetson became also slower because of less processing speed.

It looked like it was a thermal problem. I ran the tegrastats and below shows the last line for 5W and 10W without a fan and then it powered off:
For the 5W:
RAM 3160/3965MB (lfb 107x4MB) SWAP 42/4096MB (cached 3MB) CPU [98%@921,98%@921,off,off] EMC_FREQ 0% GR3D_FREQ 9% PLL@49.5C CPU@53C PMIC@100C GPU@51C AO@62.5C thermal@53C POM_5V_IN 2728/4064 POM_5V_GPU 120/1157 POM_5V_CPU 882/853
For the 10W:
RAM 3093/3965MB (lfb 107x4MB) SWAP 57/4096MB (cached 9MB) CPU [37%@825,21%@825,21%@825,21%@825] EMC_FREQ 0% GR3D_FREQ 98% PLL@34C CPU@37C PMIC@100C GPU@37C AO@48.5C thermal@37.5C POM_5V_IN 6583/6170 POM_5V_GPU 3429/3015 POM_5V_CPU 709/814

So I bought the recommended fan Noctua NF-A4x20 5V PWM and then running in 10W and even jetson_clocks gave no problems anymore.

With fan the Jetson Nano kept running and AO didn’t reach high temperatures. Maybe there is a dT/dt protection in the Jetson Nano because the 5W raises the remperatures slowly and resches higher temperatures than in 10W mode? I didn’t read it in the thermal design guide.
With a fan 5W the max AO temperature measured was 42C and for 10W and jetson_clocks 50C.

Looks like a fan is obligatory for deep learning applications and I think it should have been added to the NANO-DLI-KIT.

Another issue I didn’t mention but does not occur everytime so it is hard to put a finger on it, is that when powering the Jetson Nano on, it sometimes turns off immediately. Then powering on again the Jetson Nano remains on. I used the Mean Well 5V 4A adapter included in the NANO-DLI-KIT. My guess explanation is that when the Jetson is fully discharged there is a surge current because of the capacitance of capacitors and USB leads and wires that is higher than 5A and this lowers the voltage. Because the capacitors are charged the second time the surge current is lower. It is a wild guess and I don’t have equipment to measure it. As said it does not always happen but I bought a Mean Well 5V 6A adapter as a backup adapter to test this. It hasn’t happened yet with this adapter.

Hi mahabiersing,

Per your description of normal work with 5V 6A adapter, it looks like the workload during power on is so much that 5V 4A adapter failed to power on system. It might happen as the full discharge caps will draw some current when power on, or the devices attached do the same. Basically if no external devices and power supply is good, 5V 4A should be able to power on system without issue.

hello, i have same issue, its madness already((( i have prooved 5V 4A DC https://www.meanwell-web.com/en-gb/ac-dc-dual-output-enclosed-power-supply-output-rd--65b and 5W mode is not suitable, i need $ sudo nvpmodel -q NVPM WARN: fan mode is not set! NV Power Mode: MAXN 0 for my payload. and test running ends abnormally, jetson switched off. im sure about DC power, i checked it.
what to do? please help asap.
photo:
https://drive.google.com/file/d/1Nbu46GDaPnuOokkXdhc7rlaDBjZf9ra5/view?usp=sharing

The message “NVPM WARN: fan mode is not set!” is new for me. Maybe you have a newer version of L4T.

But I don’t see a fan on your heat sink. The greatest cause of my issues was thermal. Installing a fan like the Noctua NF-A4x20 5V PWM solved already the first three issues. I only have issue #4 when I use the 5V 4A adapter and only the first time starting up. The second time it keeps running until I turn it off.

Hi maxrodkin,

It looks like thermal issue, you can read the thermal zone value to confirm. Thermal design guide lists the method to read. https://developer.nvidia.com/embedded/dlc/jetson-nano-thermal-design-guide-1.2 , if it is thermal issue, a good thermal solution or external fan is necessary.

Hi Trumany,
tegrastats says:
RAM 3430/3956MB (lfb 62x4MB) SWAP 196/1978MB (cached 1MB) CPU [38%@921,32%@921,off,off] EMC_FREQ 0% GR3D_FREQ 0% PLL@28.5C CPU@33.5C PMIC@100C GPU@31.5C AO@35C thermal@32.5C POM_5V_IN 2615/2451 POM_5V_GPU 76/157 POM_5V_CPU 653/553

so, the 31.5C is seems normal. Are you sure about cooler fan?

If not thermal problem you might need to probe if any voltage drop happen before shut down abnormally. Do you have other power supply more than 4A to try?

yes. i have ATX supply with 5V/40A. But i`m sure about power stability. I beholds my voltmeter during all testing process, 5.06V was stable. Proof - my photo link above

You are measuring 5.06V at the power adapter output. And then there is a two-wire cable. What is the voltage at the barrel with the same current running?

This needs a oscilloscope to capture possible drop at the DC barrel. That can help to confirm if any peak power consumption make system shutdown.

well, i checked DC with piece of penchel. The voltage was same 5.06V unver 3A of circuit power. The photo:
https://drive.google.com/file/d/1KGAjUiL1R7Aj4vHl74NwsISAuXgZBGTL/view?usp=sharing
i switched off the power, then the isolation starts to burn.
Do you really believe in mistery voltage drop?

Only from HW point, generally the drop is a very short pulse, only oscilloscope can capture it by trigger, multi-meter has no such function. Power supply might have transient response ability problem even though its output capability fits request.

Do you have full log till shutdown happened? It might be useful to check root cause.

actually, i setted up fan.
beside that, i connect DC not to jack, but in j40 2-6 pins. It`s most reliable case.
The photo:
https://drive.google.com/file/d/1xE9pg88PI88DVw4MPVny4s5kLaF61yCD/view?usp=sharing
result is same - jetson swithced off under GPU payload.
Resourses not loaded fully before die:

RAM 3516/3956MB (lfb 29x4MB) SWAP 139/1978MB (cached 2MB) CPU [41%@1428,46%@1428,75%@1428,48%@1428] EMC_FREQ 0% GR3D_FREQ 0% PLL@23.5C CPU@28C PMIC@100C GPU@25C AO@30.5C thermal@26.5C POM_5V_IN 4921/2143 POM_5V_GPU 788/101 POM_5V_CPU 1728/513

3 [|||||||||||| 37.7%] Uptime: 00:15:29
4 [|||||||||| 28.8%]
Mem[|||||||||||||||||||3.21G/3.86G]
Swp[|| 111M/1.93G]

PID USER PRI NI VIRT RES SHR S CPU% MEM% TIME+ Command
9047 root 20 0 11.5G 1670M 481M D 57.1 42.2 0:14.38 /usr/bin/python -
6496 nvidia 20 0 984M 88788 32648 S 4.6 2.2 0:33.37 /usr/bin/compiz
8117 nvidia 20 0 8984 3100 2216 R 3.3 0.1 0:09.95 htop

I think, jetson have weak in his power construct. I dont see any futher steps to disprove it.

hi, i got /var/log/syslog throw rs232 port connection by command
tail -f /var/log/syslog.
The file https://docs.google.com/document/d/1LgUAz7CmtNlOFq7jVRoA3EXwc3fYpK9mBUgfJiMieUg/edit?usp=sharing
SPOILER: nothing interesting there.
So, whats next?

hello Trumany ,
so , what would you say?

Is this really the log which is before the device power off…?

The only thing I see is a boot log plus some syslog…
Also, why the syslog looks out of order…?

Is there any running application when device is dead?

yes, there is tail of syslog.
From begin:

  1. connected jetson to comp USB0 port throw CP2102
  2. booted jetson
  3. had login to jetson throw moserial throw USB0 port
  4. tail -f /var/log/yslog
  5. ran python3 torch powered app
  6. jetson dies
  7. collected log

support, how i can return my Jetson to RMA?