Jetson Nano Access Point WIFI signal is unstable

I added an Intel 8265NGW wireless adapter to Rev B carrier board and configured it as an Access Point. I can connect the AP from my laptop and upload and download the files. It works but NOT reliable.
I use NetSopt software to monitor the signal strength from my laptop. Look at the picture below. The top line(without broken) is the WIFI router signal strength. The lower part is the Jetson Nano Access Point signal strength. You will see, it is no signal sometimes.

How can I sort out this issue?


Is there any suspend setting on device?

The test is based on Nvidia SD card image from the file of The hostapd has been installed.
This is hostapd configure


# High priority/AC_VI = video


# Limit the number of connections to 3 during development
# TODO: set this to 2 for pre-production

# Security

# Auto generated -- do not edit anything below this line

I got a support from Intel on this case.
This is response from Intel support:
With regards to your concern, we were able to replicate the issue on our end and the connection was stable. However, the kernel version we used was 5.4. In this case, it is suggested that you update the kernel version of your system to 5.4 and see if it would resolve the issue.

Is there plan to upgrade the Linux kernel to 5.4?


Hi changwen,
Now Jetson latest version is Jetpack5.0.2 which kernel is 5.1, 5.4 will support in future. You can try 5.0.2

I installed JetPack 5.0.2 on host PC successfully. But after connected the Jetson nano develop board, the JetPack 5.0.2 is disabled. And the latest JetPack version for Jetson nano is 4.6.2 which does not support Linux kernel 5.1.
What Can I do for it?


Hi changwen,
Sorry I missed it it Nano, for Nano only JP4.* support which kernel is only 4.9. So if need kernel 5.*, you need test on Xavier series.

Hi Jeffli,
It is impossible for us to change to Xavier series now.
Is there plan to upgrade the Linux kernel to 5.4 or higher for Jetson nano?


Hi hangwen,
JP5.0 or higher will not support Nano. you should change another wireless adapter on Nano.

Any suggestion on WIFI adapter to work as Access Point and compatible with Jetson nano latest image?


To have a quick try to confirm if there is a power suspend there, pls try with the followed command and monotor the status again.

sudo systemctl mask

I just tried your command. It does NOT sort out the issue.

In that case, it may not caused by the power.
Have you ever see a mode switch in your system? like from AP to station mode and back, or there is some errors there. This could be record in the kernel message.

Need to figure out if this is something related to wifi firmware or the system.

Would you please give me the details info where and how can I get the message as you expected? from syslog?
There is a WIFI router close to the Jetson nano AP. The WIFI router’s IP is It is working auto channel mode. The Jetson Nano AP is using static IP at: It is working in fixed channel mode. I tried on channel 1 and 6. Both channels have the same issue.


Need to figure out if it’s an issue from the driver/firmware or the AP itself.
Is the nano stable enough to working in station mode? just connected to another wifi router to watch the connections as you do with NetSopt.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.