Jetson Nano Boot Problems

Hello guys!

I really need your help, i tried to clone my system into a SD card, because the eMMC chip was already full. Did everything the guide instructed, but when i modified the extlinux.config file on the Sd card, and then reboot, i don’t have any OS now, the nano wont boot into anything, with, or without SD Card…

Any advice?

I have another Jetson Nano (without SD card port) that maybe i can use to access the eMMC chip and modify something?

I am kinda lost

Please help!

The tool you’d need for investigating that is a serial console:

that would give visibility to early stages of boot flow and errors if any.

This would be an USB/serial interface, be sure to use on with 3.3V. Then using host you would be able to set up a terminal as console using minicom or gtk-term with Linux, or puTTY or TeraTerm from Windows, finding the relevant USB device and configuring it for frame 115200-8N1.

You may then check what config boots or not, and if one boots to login try checking available disk space.

If you have saved all the data/code/else from eMMC by cloning, you may just reflash eMMC and reinstall.

There may also be ways to clone into a raw image on host that you could be able to loop mount in host for editing before reflashing Nano, but someone else may better advise for doing that.

I have a J1010 device, that has internal eMMC, the console link shown shows difference jumper that i do not have…

I really don’t understant nothing you said… isn’t there a way to just erase the eMMC with a new fresh install and call it a day?

Not sure I correctly understand, seems you’re using a Nano Production Module with embedded eMMC, but I don’t yet know what is a J1010 device. Is it a custom host motherboard ? From which vendor ? You may contact them for serial console connection guide.

Seeed Studio is the brand

This should be able to boot from the SD card by me choosing a boot device. It is so difficult without it.

I don’t mind installing everything again, but as soon as i power on, it reads the eMMC instead of the SD card, and wont boot

What JetPack version are you using ?

Reflashing from SDKM without the SDCard inserted would probably give a fresh install, you would have to update and reinstall your own SW.

Note that since JP5.x.x UEFI support came and there might be a possibility to have different boot devices hosting early boot partitions and may be able to boot different L4T versions starting from JP5.

So the best way for your case may need some details about what release you’re using and what is your goal for cloning.
Basically if you’re just lacking disk space on eMMC it should be enough to clone the APP partition from eMMC into SDCard with rsync and then try adding a second extlinux config for trying booting to that rootfs, then using serial console (that seeds would have told how to setup), you would be able to try this new config and if ok set it as default. There might be additional steps for OTA upgrade, but should be enough for now.

Don’t know which jet pack, probably the latest one.

To be able to use SDK I. Need a computer with Ubuntu, which I don’t have, it’s not compatible with 18.04 LTS, and I can’t do it with terminal because the other nano I have that runs 18.04, it’s only 16gb and I can’t download the required files….

I have a perfect clone in a Sd Card, but the device won’t seek for another boot drive; only the eMMC, which have the extlinux.config file corrupted I guess.

I will contact seeed so they solve my problem, otherwise I will return the device to them.


Do you have any trace of the modifications made to your extlinux.conf ? and how you cloned ?

Ok, so I used this

When I finished, I opened the EXTLINUX.CONFIG from the SD card, and changed the root to boot from the sd (previously found the name was mmcblk1)
So what I did is change mmcblk1p1 (that’s eMMC) to mmcblk1 (SD).


And when I rebooted, nothing happened, only had the NVIDIA screen and the some texts .

So me said FAILED Another ones OK

failed ones:

and then goes to a black screen forever….

Seems wrong, Not 100% sure for your case, but I would expect eMMC to be mmcblk0 (and mmcblk0p1 to be partition1 on that disk) and mmcblk1 to be SDCard.

P1 was there before touching anything, and that pointed out as eMMC.

In the Disks app, the SD card was shown as mmcblk1, that’s what I changed it for

mmcblk0 is a disk (eMMC) as mmcblk1 is a disk (SDCard).
mmcblk0p1 is partition 1 of eMMC, mmcblk1p1 is partition 1 of SD card.

Did you clone the whole disk or just APP partition ? Can you share what you did (exact edits/commands) ?
Sorry I don’t have experience with these seeds modules/SDK, you may get better support from them.

Don’t really know, I followed the guide, and all from the eMMC got cloned into the SD card, then I modified the config file for booting, and everything got complex…

As you’re having issues with a procedure from Seeds on a Seeds carrier board, you may want to post your issue to Seeds forum. I may only be able to help for general issues that can be reproduced on standard devkits.

Will do!

Once everything is solved, we can get back to the OBS and GoPro project!

Thanks bud

1 Like

If you get your OBS Studio software working let us know, it’d be a good addition to projects.

One comment is that if you have serial console to pick boot from you are better off leaving the original entry in place, and making an edited copy of the original entry. Then, with serial console, you could pick which entry to boot from. Once tested either entry could be made default.

For OBS, you may try this.

Thanks for the OBS build tip! At some point I will try this. In the past it seemed like there would be a lot of utility to be able to do things like make tutorials directly on a Jetson. One of the primary restrictions of course is to have enough disk space (build versus just install takes a lot more).


So i contacted the people from seeed, and they are useless, in short, i have to install the OS again using SDK manager.

So i have triend everything, running Ubuntu 18.04 LTS on my Lenovo Laptop, on my Mac book Pro, and even on my raspberry pi 4, i just cant install the SDK

It says there are dependancies (libconf -2-4 , libcanberra, etc, but this guys are obsolete when trying to install them on my system)

i just dont know what else to do, why is this so difficult!!!

please, if you have any idea on how to get this SDK running to flash my EMMC from the jetson, i will appreciate it!


dont really know how… but i got the app running… i manually added APT so it installs the dependancies…

on my way to flashing the jetson! ill come back for the OBS project