Jetson nano boot process hangs at

Hi,

I tried to bring up the nano board using kernel built using kernel source from below link:- 

https://developer.nvidia.com/embedded/linux-tegra

The toolchain which is used to build the kernel is Linaro 7.3.1 2018.05 toolchain downloaded from below link:-
http://releases.linaro.org/components/toolchain/binaries/7.3-2018.05/aarch64-linux-gnu/
Followed the setps from below link to build the kernel:-
https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%2520Linux%2520Driver%2520Package%2520Development%2520Guide%2Fkernel_custom.html%23wwpID0E01C0HA

I flashed the jetson-nano-sd-r32.1-2019-03-18.img to the sd card. Copied the Image and dtb files from path TEGRA_KERNEL_OUT/arch/arm64/boot/Image and TEGRA_KERNEL_OUT/arch/arm64/boot/dtb/ of built kernel to boot directory of sd card. Also copied the kernel modules to lib directory of sd card and tried to boot board using this sdcard.
It started booting process then asked to accept NVIDIA Jetson software EULA, then Select system language, keyboard layout, and time zone and asked to create username, password, and computer name.
After that it started system configuration. Then screen becomes blank for some time and then it goes to boot process and hangs at " [ OK ] Started Update UTMP about System Runlevel Changes ".

Does anybody have a similar situation?

Thanks

1 Like

Please also put the kernel image /dtb to the Linux_for_Tegra/kernel/ and Linux_for_Tegra/kernel/dtb on your “host” and do the flash.

I’m having this same issue. I’m using this build: Jetson-210_Linux_R32.2.0-0.tbz2 and followed the steps here: https://devtalk.nvidia.com/default/topic/1038175/jetson-tx2/tx2i-wifi-support/post/5274619/#5274619 and https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide%2Fkernel_custom.html%23wwpID0E0ZC0HA

  1. Downloaded the latest SD Image
  2. Flashed to Disk
  3. Downloaded the build onto Jetson Nano (Jetson-210_Linux_R32.2.0-0.tbz2)
  4. Unzipped
  5. Created and folder
  6. Copied current kernel configuration (by getting a copy of /proc/config.gz) to and renamed to .config
  7. Ran 'make nconfig' to customize kernel (to add CONFIG_LOGITECH_FF=y)
  8. make -j4 O=$TEGRA_KERNEL_OUT
  9. make -j4 O=$TEGRA_KERNEL_OUT modules
  10. make O=$TEGRA_KERNEL_OUT modules_install INSTALL_MOD_PATH=$TEGRA_MODULES_OUT
  11. Copied Image to /boot/Image-custom
  12. Copied dts files to /boot/
  13. Copied files to /lib/modules
  14. adjusted '/boot/extlinux/extlinux.conf' to boot Image-custom

When booting up, it gets stuck at “[ OK ] Started Update UTMP about System Runlevel Changes”

I tracked it down to not copying all of the module/firmware files correctly. When I copied the $TEGRA_MODULES_OUT/lib/ to /lib/, the system was not able to find/load all of the needed modules.

Going back, I copied the whole $TEGRA_MODULES_OUT to /, and was able to boot up successfully.