Jetson nano boot troubleshooting

I recently ordered 5 Jetson Nano 2GB and I’m having problems booting 3 of them.

2GB edition
Carrier card ID: p3541 180-13542-daaf-a02
SOM: p3448 180-13448-daa-b01

*I’ve tried different SD cards from the ones working. I dont even get to the Nvidia logo when plugging in the USB-C power connector.
*I’m using approved Raspberry Pi 4 USB-C power supply (3A 5V). I’ve also tried other 15W USB-C supplies.
*Ive tried connecting to the UART TX to read data using baud 115200 8N1 and still only get gibberish…

I want to try force recovery but all the guides are for other carrier boards it seems. The connector with FRC is called J11 on my carrier.

I want to follow this for force recovery: Tegra Linux Driver

But the carrier connector identifiers does not match my carriers (I dont have J40, J48 or J25). How do i enter force recovery on my carrier?

Best regards

UART should work. If this is gibberish, then it implies either (A) the non-Jetson half of the UART is not running at a 3.3V TTL logic level (is your UART 3.3V?), or else (B) it only appears as gibberish due to a different character set on the host PC side (on the host PC command line, what do you see for “echo $LANG”?). If everything is correct (115200 8N1 is correct), then something quite odd is going on (possibly hardware failure). A serial console boot log would be very useful.

Btw, I don’t know enough about the 2GB models to say what carrier board compatibility they have, but possibly an incorrect device tree could also lead to this. In the case of a dev kit using the dev kit carrier board I wouldn’t worry about this. If there is anything unusual (or custom) about this though, then you might want to add details.

hello erikamgard,

are these 5 Nano platforms flashed before?
did you shutdown the board after it’s boot success and also unplug the sd-card immediately? this may crash the board since it’s background service executed for the 1st time boot-up and copy/update binaries, this process takes around 5-10 minutes.

btw,
please refer to Developer Kit User Guides and gather bootloader logs for reference,
thanks

Hi and thank you for the response. I previously used an RS232 adapter to read the UART and as you said, the voltage levels were probably a bit off. I bought a TTL<->USB cable and can now read the boot info:

[0000.163] [L4T TegraBoot] (version 00.00.2018.01-l4t-e82258de)
[0000.168] Processing in cold boot mode Bootloader 2
[0000.173] A02 Bootrom Patch rev = 1023
[0000.177] Power-up reason: pmc por
[0000.180] No Battery Present
[0000.182] pmic max77620 reset reason
[0000.186] pmic max77620 NVERC : 0x40
[0000.189] RamCode = 1
[0000.191] Platform has DDR4 type RAM
[0000.195] max77620 disabling SD1 Remote Sense
[0000.199] Setting DDR voltage to 1125mv
[0000.203] Serial Number of Pmic Max77663: 0x1b10e1
[0000.211] Entering ramdump check
[0000.214] Get RamDumpCarveOut = 0x0
[0000.217] RamDumpCarveOut=0x0, RamDumperFlag=0xe59ff3f8
[0000.222] Last reboot was clean, booting normally!
[0000.227] Sdram initialization is successful
[0000.231] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.237] Lp0 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.243] BpmpFw Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.248] GSC1 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.254] Resize the SecureOs Carveout to 0x00100000
[0000.259] GSC2 Carveout Base=0x00000000ff900000 Size=0x00100000
[0000.265] GSC4 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.271] GSC5 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.276] GSC3 Carveout Base=0x00000000bf800000 Size=0x00200000
[0000.282] RamDump Carveout Base=0x0000000000000000 Size=0x00000000
[0000.288] Platform-DebugCarveout: 0
[0000.291] Nck Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.297] Non secure mode, and RB not enabled.
[0000.301] BoardID = 3448, SKU = 0x3
[0000.305] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.308] Nano-SD: checking PT table on QSPI …
[0000.313] Read PT from (2:0)
[0000.328] Using BFS PT to query partitions
[0000.332] PT: Partition TBC NOT found !
[0000.336] Warning: Find Partition via PT Failed
[0000.340] BoardID = 3448, SKU = 0x3
[0000.343] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.347] Nano-SD: checking PT table on QSPI …
[0000.352] PT: Partition TBC NOT found !
[0000.355] Warning: Find Partition via PT Failed
[0000.360] Error is 1

EDIT: I’ve also tried connecting the board to a 64-bit Ubuntu 18.04 laptop using Nvidia SDK but I cant seem to find the board inside SDK…

hello erikamgard,

there’re errors regard to partition reading failure. please do have a try to re-flash the board to resolve the issue.

sometimes the laptop cannot recognize the target due to the USB connection.
you should try to use other usb ports or select one better usb cable to have confirmation.
thanks

The same USB port and cable can be used to find the working Nano’s in SDK. The host pc does not even list the device under /dev/tty*. The problem must be the board itself

I was able to flash the Nano without the Ubuntu host being able to recognize the board. Using “manual setup” and connecting a jumper on J12 (not J11!) on pins 9 and 10 to enable force recovery mode . Also formatted the SDCard before flashing.

The card now boots and works properly :) Thanks for the help

Incidentally, the interface isn’t RS-232. The protocol is the same, but the PHY won’t work with the older 9-pin D-shell connectors…voltages are wrong and must be 3.3V. It is possible for the D-shell connector voltages to actually damage the Jetson.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.