Jetson nano emmc module (p3448-0002) audio interface

Hi all

I tried converting the device tree to enable the i2s interface on the emmc(p3448-0002) module, but the audio doesn’t work. I found a way to change the state of pins through the U-boot console. This method works, but it needs to be done every time you start. In other topics I found mention of the same problem and a recommendation to use a table in Excel to create a device tree. I tried using the table in Excel and my manual configuration is the same as the configuration obtained using the table in Excel. I tried using the new device tree, but the result is the same.
In one of the topics (Enable audio(I2S) on Jetson nano emmc(p3448-0002) with Jetson carrier board(p3450) 7 ) I found a way that requires changing the gpio driver (But will it work?)
Can you give me any recommendation? Perhaps I missed something during setup.

Best regards, Georgiy

Suggest to follow the thread you posted, and you can ask the poster if he/she can share more experience with you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.