Jetson Nano fail bootup


I have been working with the Jetson Nano since the past week. I was successful in booting up and running deep learning programs on the Jetson Nano using SanDisk 16 GB memory cards. The board is connected to a Samsung monitor via HDMI. a keyboard and mouse via USB.

I wanted to use a 32 GB SD card so I flashed the jetson nano image onto that (a microSDHC Memory Card by MetroPCS - last minute buy) and tried booting up with the same configuration as above. I run into an error:

[1.099316] tegradc tegradc.1: dpd enable lookup fail:-19
cp: not writing through dangling symlink ‘etc/resolv.conf’
[340.0486791] cgroup: cgroup2: unknown option “nsdelegate”

The system hangs after this.

I have checked the forum for answers but most answers pertain to proper connection of the peripherals (HDMI cable, etc). Since my system worked with the same setup for a different SD card, I was wondering if the current SD card is not supported.

Edit: I seem to be getting the above messages for successful bootups too. But why is the bootup failing with this SD card?

What are the last messages that print?

The last message that prints is:
(2 of 3) A start job is running for Create Vol title Files and Directories (3min 7s/no limit).

The process hangs after this and restarts.

I get two other failed processes earlier in the bootup process:
[FAILED] Failed to start Load/Save Random Seed
See ‘systemct1 status systemd-random-seed.service’ for details
[ ] (7 of 7) A start job is running for Set the console keyboard layout (1min 38s / no limit)[522.115879] systemd[1]: Failed to start Load Kernel Modules
[FAILED] Failed to start Load Kernel Modules

I am having the same problem with a 32 GB sandisk microSD card with jetpack 4.4

Did you solve the issue?

Hi zabiralnabil,

Please open a new topic for your issue. Thanks