Jetson Nano Fan control - set to auto

Hi,

What is the command to set the pwm fan to auto mode?

I used, To set max RPM: 100%
#echo 0 > /sys/devices/pwm-fan/target_pwm
(use 255 to 0 values to change the duty cycle/ RPM)

for 50%
#echo 127 > /sys/devices/pwm-fan/target_pwm

for 0%
#echo 255 > /sys/devices/pwm-fan/target_pwm

but now wanted to set it to automatic based on the module temp

hello vbhm,

do nothing. fan should turn-on by default when thermal above 51 degree.
please refer to Thermal Specifications for reference,
thanks

I have set it to echo 0 > /sys/devices/pwm-fan/target_pwm and now fan is off,but not getting ON even temp is more than 50

hello vbhm,

you should not have specify the target_pwm, since it’ll overwrite the settings.

Ok, my requirement is to set the fan to 100% duty cycle, then 50 then 0 and then reset to auto. how should I make this?

Hi Vbhm,

Can you please try simulating the callbacks from thermal subsystem to override the pwm values and let us know the status.

Steps:
Allow sw override: /sys/kernel/debug/bpmp/debug/soctherm/temp_sw_override

temp override knobs to tweak:
/sys/kernel/debug/bpmp/debug/soctherm/group_<Thermal_Group>/temp
Thermal_Group: AUX, CPU, GPU, PLLX

Modifying the temp will essentially invoke the callbacks and adjusts pwm value dynamically irrespective of the earlier set target_pwm value.

Thanks & Regards,
Sandipan

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.