Jetson Nano GPIO setting LOW or HIGH problem

Hello,

I have a Jetson Nano Developer Board and i tried to power up another device with Jetson’s GPIO port, similar to ESP32 set PIN method.

I read these documents with no luck:
https://levelup.gitconnected.com/program-gpio-on-raspberry-pi-and-jetson-nano-with-multiple-languages-b937c456f96b

The ESP32’s method works like this: Configure GPIO 33 as digital I/O - ESP32 Forum

Is there any way to control Jetson’s GPIO similar to ESP32?

Thanks in advance.

Your sincerely:
Peter

hello peter90,

could you please refer to GitHub - NVIDIA/jetson-gpio: A Python library that enables the use of Jetson's GPIOs,
thanks

Dear JerryChang,

Thank you for your reply. I read this description, but it not helped. Let me to clarify my problem. I try to power up another device with Jetson’s GPIO ports. I have two wires (PWR and GND, generally red and black wires). My question is is it possible to do this in this way? Or i need another device, circuit or anything else?

I have default installation with the latest JetPack version (4.5.1). I didn’t set up pinmux. I tried the samples in this directory (/usr/share/doc/jetson-gpio-common/samples). The test_all_pins.py script didn’t helped me.

So i ask for help in this issue.

Thanks in advance.

Your sincerely
Peter

hello peter90,

you’re working with 40-pin expansion header, port J41, right?
please check Jetson Nano J41 Header Pinout for provided voltage.
you may also check Applications Note of 40-pin expansion header for reference,
thanks

Dear JerryChang,

Yes, I’m working with a 40-pin expansion header (port J41). I read the desciption what you’ve sent, i understand and i read about TXB voltage translator before. I tried to configure GPIO port based on this description (https://maker.pro/nvidia-jetson/tutorial/how-to-use-gpio-pins-on-jetson-nano-developer-kit) without luck. I tried to measure the output voltage on GPIO 18 port, i measured 1.4V with and without HIGH settings. I tried to measure additional ports too, but I experienced the same. Could you help me to find the right settings to set described port HIGH or LOW position?

Thanks in advance.

Your sincerely
Peter

hello peter90,

could you please check this topic as see-also.
thanks

Dear JerryChang,

I read the description what you sent, but it wasn’t helped to me. I try to solve this issue another way. Thank you for your help.

Have a nice day! :)

Your sincerely
Peter

hello peter90,

am I understanding correctly that this issue has already resolved.
please share some info for reference, thanks