Jetson Nano: Hello world generates segmentation fault


I am new to Nano and want to try the Hello world demo. Jetpack 4.2 is installed and the demo works properly with the console. If I run the camera demo, a segment fault is generated. Camera is Logi c270.

gstreamer] gstreamer stream status ENTER ==> src
[gstreamer] gstreamer changed state from PAUSED to PLAYING ==> capsfilter0
[gstreamer] gstreamer changed state from PAUSED to PLAYING ==> nvarguscamerasrc0
[gstreamer] gstreamer msg stream-start ==> pipeline0
GST_ARGUS: Creating output stream
CONSUMER: Waiting until producer is connected…
GST_ARGUS: Available Sensor modes :
Segmentation fault (core dumped)

I have tryed several commands with C++ an Python, allways with the same result.

Any hint is very welcome.

Regards Walter

It isn’t detecting your sensor correctly - it looks like it is setup to use MIPI CSI camera. In the tutorial, there is documentation on launching with the --camera flag to specify the camera device (i.e. --camera=/dev/video0)

Hello Dusty,

Many thanks for your hint! Your mentioned option work very well, it was the only one, which I did not test.

Regards Walter