Jetson Nano UART control SIM7600SA-H Problom

I am using the Jetson Nano’s UART to control SIM7600SA-H through AT command.
It is fine if i use usb-to-tty.
but i cann’t find anything by using J44’s UART1 or J41’s ttyTHS1.

Can someone help me ? QAQ

hello andy26283,

please check for communication with Nano by using J44.

hello JerryChang

I know this blog, and I also do the same thing.
It is OK to using J44 to connect the PC.
but i cann’t using J44 to connect the UART device(SIM7600SA-H).

If i use the usb-to-tty(usb with Nano, tty with SIM7600SA-H), it is ok to read or write the device.
but i use the J41 or J44, it cann’t read anything or write anything.

Am i miss some command about open J41 or J44’s UART?

hello andy26283,

please review your connections, had you connect TX/RX correctly?
also, please also check the configured baud-rate settings.

Yes, I very sure I correctly connect TX/RX, and I also sure the baud-rate settings is correct.

Do I need to do “Disable Console over UART”( if I want to use J41 to connect?

Is J44 have the same setting about using the ttyTHS1?

hello andy26283,

please check similar discussion thread for setup serial console with J41 and J44 on Nano.

  1. please refer to Topic 1062786 for J41.
    since we had verified by connected TX (pin 8), RX (pin 10), GND (pin 6) on J41, communicate with /dev/ttyTHS1
    you might check with having getty on background to ensure transferred properly without any data loss.
    for example,
$ sudo /sbin/getty -a ubuntu -L 115200 ttyTHS<port> &
  1. please also check Topic 1062289 for enabling J44 for Jetson-Nano. thanks

Hi andy26283,
very impressed that you got this far with the SIM7600. I’m trying to install atm and getting very frustrated with the scant setup documentation. Did you have any issues, or any tips to get it running? I think I have a happy board, PWR led is up and NET led is flashing every 3secs. But minicom is not echoing input/responding when run and the example is also not responding. Looks like I’ve missed a fundamental setting, but lack of documentation is not helping.