Jetson nano serial communication

I am trying to communicate jetson nano with linux machine. I have used UART 2 on J41 header with pins 8, 10. I am unable to locate the port as “/dev/…” For communication I am using python. Tell me the correct procedure for serial communication

hello garimakaushik134,

please check NVIDIA Jetson Nano J41 Header Pinout for the J41 pinouts.
you may also check Topic 1051560 for reference.
please note that you should configure the baud rate as 115200/8N1.
thanks

Hello I have configured the baud rate as 115200 8N1 , on both jetson side and PC side. The respective port is ‘/dev/ttyTHS1’. From PC to jetson data is sent successfully, but from jetson I am reciving random data as follows:
Nvidia is my jetson
PC serial ready…
('Nvidia: ', ‘\xc8\xe5\xfc\xeb\x8b\x047\xe5\xe9sS5+\xfe’)
PC serial ready…
('Nvidia: ', ‘Hglok+/\xf9\xbd\xbb\x02\xfa\xd3\xfe’)
PC serial ready…
('Nvidia: ', ‘Je\xfcl\x7faXCo\xee.\x92\xc8\xfe’)
PC serial ready…
('Nvidia: ', ‘Jg|l\x7f\xf8U\xae\xc9~\x12\xfe_\xfe’)
PC serial ready…
('Nvidia: ', ‘hY[\xeb\xe1P\xc7\xf7s\xa1\xbf=\xfe’)
PC serial ready…
('Nvidia: ', ‘H\xe7l\xfco9UCn.n\xa0=\n’)
PC serial ready…
('Nvidia: ', ‘Xel|\x7f;\xd2\x94r\xbe!\x8d\x85’)
PC serial ready…
('Nvidia: ', ‘Xm[[\x0b\t\xd5\xb4\xc9r\x81M\n’)
PC serial ready…
('Nvidia: ', ‘\xb4\xfb\xb7\xbe\x0f-\xb5\xca\xc9\xcf9\xbdr’)
PC serial ready…
('Nvidia: ', ‘Xeln\x7fpXx\xef\xe9\t\xe9J\xfa’)
PC serial ready…
('Nvidia: ', ‘melm\x7f\xa4\xac(\xd9\xd9\x19\xa9\xee\xfe’)
PC serial ready…
('Nvidia: ', ‘H\xf5l|\x85a\x1dn.\xee\xa5C\xe9’)
PC serial ready…
('Nvidia: ', ‘H\xf5\xec|\xef$T(zr\x0bM\x95’)
PC serial ready…

Has anyone checked??

Hello
I have tried to resolve this issue, the default port for serial communication is ‘/dev/ttyS0’ and I was using ‘/dev/ttyTHS1’. The serial services running can be checked through:

ls /etc/systemd/system/getty.target.wants

The output is:

getty@tty1.service  serial-getty@ttyGS0.service

It shows that the port ‘/dev/ttyTHS1’ is not active serially, so I used ‘/dev/ttyS0’, still communication fails

But my other doubt is, how can I use two UART’s simultaneously…??

hello garimakaushik134,

for Jetson-Nano, please try to connect J44 and J41 to use two UART.
thanks

I’m running into the same issues and can’t get a basic loopback test working as described in this thread:
https://devtalk.nvidia.com/default/topic/1051572/jetson-nano/jetson-nano-issues-comunicating-with-stm32-through-uart/

Specifically, I’ve wired J41 pins 8 to 10 and tried /dev/ttyTHS1 and /dev/ttyTHS2 using a couple comm programs.

Is some kernel parameter required to enable the uart?

Joined this thread to find out port number for J41.

Set up J41 as null modem (looped Tx to RX)

Downloaded minicom and set up a couple of defaults; tried /dev/ttyGS0, /dev/ttyTHS1, /dev/ttyTHS2
all not working try others also finally tried /dev/tty and it worked.

I will eventually try it on my other Nano.

I want to use J41 to control a serial motor drive that uses RS-232 TTL; can anyoneverify that I
need a signal level shifter or not.

Thank you!

Please ignore last message. Evidently /dev/tty echoes itself.

I probably will have to use j44 uart.

You need to disable the nvgetty service. See https://github.com/JetsonHacksNano/UARTDemo