j44 header pin as normal serial port

I am new to jetson nano

I Connect to j44 and PC using serial uart program teraterm
and run serial communication c program on jetson nano “/dev/ttyS0”

When I connect to jetson nano using com port to using serial program on pc

teraterm log receives requires id, pwd input
and other console command

I don’t need admin console terminal
I just want serial communication between jetson serial j44 and pc console program
Are there possible to j44 only normal serial communication, get rid of console log.

hello dkrnd4365,

assume you had setup an environment as following, https://www.jetsonhacks.com/2019/04/19/jetson-nano-serial-console/
you could use the ubuntu terminal to communicate with Jetson-Nano (such as minicom, picocom),
please also note that the baudrate settings should be 115200/8n1
thanks

I can’t use minicom, picocom tool ,
but I have to programming in c language to communicate jetson and pc using j44 pin.
Would you show me the sample source in c language not minicom ?

I already used j41 and will add j44 for uart communication

first jetson side i use customized c program
and pc side i use my customized c program

When i connect from pc to jetson
from pc side I received admin console log from jetson
I don’t want admin console log

when running Jetson side my custom serial program
after 30 sec - 1 min, my jetson side serial program occur core dump.

my purpose is using serial j44 same to j41 serial port(uart)
i using j41, serial program running well both side(jetson-pc).

I connected J44 (TX,RX,GND) with Prolific USb-to-Serial Comm and
Run Putty program in PC Side.
But
I can’t view any message on putty

Putty Serial Configuraion is 115200 8 None 1 Xon/Xoff

What should I review ?

Thanks for your reply

When I connect jetson using teraterm
Attach Image is here admin console log appear.

[/quote]

What is this one?
If You can’t see image file, show me your e-mail id, i will send my image file.

image.pptx (44.5 KB)

if i connect j44 using teraterm or putty

j44 requires id, pwd and acts as normal console terminal

My question is, is it possible j44 acts as j41 uart port.
j41 port only uart communication, doesn’t require id,pwd,

How can i change jetson’s config setting.

hi dkrnd4365

  1. login
  2. systemctl stop nvgetty
    systemctl disable nvgetty

then J44 will not requires id, pwd as normal console terminal

I tested it with putty with PC

I have another problem serial communication

When booting, jetson Nano send data via serial port(J41)
(ex : Ubuntu 18.04.3 LTS …)

I want to don’t send data via serial port while Jetson booting

How Can I configure Jetson Nano don’t send data while booting.

I set command below

sudo systemctl stop nvgetty.service
sudo systemctl disable nvgetty.service

Then disables send default log (ex : Ubuntu 18.04.3 LTS …)

So I solved finally, thanks