Serial Console Setup/Parameters

Hi!

What are the correct serial parameters for the Nano?

I’m trying to get serial working. Just getting meanlingless or no text output. As far as I know there are two serial console options (according to the “getting started” pdf):

  • TX/RX/GND @ the large 40-pin connector
  • TX/RX/GND/CTS/RTS @ the smaller (J44?) connector

Now I cannot get this working with either. For the latter above I am trying with baud rate 115200, 8 data bits, 1 stop bit, no parity and rts/cts flow control. When booting the kit, I see a lot of meaningless text pop up so I am definitely seeing the kernel boot messages (tried with minicom and putty). And when pressing enter I see some response. So there seems to be some misconfiguration with the transfer parameters. I have also tested a loooot of different settings… So what are the correct parameters?

hello krisrstkzp2o,

please refer to NVIDIA Jetson Nano J41 Header Pinoutfor Jetson Nano GPIO Header PINOUT.
thanks

Hi JerryChang,

But what is the serial parameters? 115200/8/1/n/R ?

And what type of hardware are you using to connect UART to PC? I suspect this may be a problem due to adapter, voltage level or something like that.

hello krisrstkzp2o,

it’s 115200n8 by default, please refer to Debugging the Kernel on Tegra Devices
suggest you refer to Jetson Nano Software Features for the UART speeds.
thanks

Thanks. Will try to connect to UART2 on J41 over the one on J44.

Just another comment: I needed an RS232 serial converter because of some issue either with serial->usb adapter voltage or serial->usb adapter flow control.

Did you get UART2 working on J41?

Something to clarify: J41 has a serial UART exposed, but serial console is not related to J41. On the Xavier the micro-OTG USB port has the ability to connect a micro-B USB cable and act as a device. One of the devices exposed is an FTDI serial UART at 115200 8N1. This implies that if you are looking for serial console you merely connect the supplied micro-B USB cable to the Jetson and the other full-sized type-A connector to the host PC.

If the host PC has FTDI drivers, then the serial UART on the micro-B USB connector should “just work” as a serial console if you point your serial terminal at the correct “/dev/ttyUSB#” using 115200 8N1 settings.

J41 is a different UART (not sure which one it is in terms of “/dev/ttyTHS#”).

Perhaps someone will need information on how to get the UART console on Jetson Nano.
Connect the USB-UART adapter to the j44 connector (GND Tx Rx), Pinout contacts look here.

https://devtalk.nvidia.com/default/topic/1048923/jetson-nano/can-t-find-j44-serial-header-pinout-information/post/5323364/#5323364

Hi @linuxdev,

I am trying to connect a Pixhawk autopilot device with the Nano using UART on J44 pins. I have gotten the Pixhawk to work with the Raspberry PI using the serial pins. I have gotten the Nano and Raspberry PI to communicate using the serial pins (through minicom). However, it seems that Nano and Pixhawk cannot communicate. Is there any way to debug this in a deeper level?

Unfortunately right now I’m trying to work on a system upgrade which isn’t recognizing my RAID/LVM combination…and my notes are on that. Someone else may be able to help, but since it is really a slightly different TX1 variant, this should work. If speed is 115200 or slower, then only one stop bit is needed. If speed is greater, then two stop bits are needed. The actual device will be one of the “/dev/ttyTHS#” devices, but I couldn’t tell you which one at the moment.

On Jetson Nano, What is the Baud rate Range for UART ttyTHS1? and How to change baud rate?
I read default baud rate is 115200. But is minimum baud rate we can set?

hello kevinpatel4400,

please refer to Jetson Nano Software Features to check the UART baud rates.
you may also update the device tree to modify the baud rates, please search “adjust-baud-rates” property for reference.
thanks

Hello, how can I disable the serial console to prevent it from taking up the serial port both during U-boot and linux. I need to use the serial port to connect to another device however because the other device is talking to the Nano during the boot process fo the nano, the signals coming from the device interrupt the boot process when u-boot prompts:

U-Boot 2016.07-g541e96c (May 31 2019 - 15:44:14 -0700)

TEGRA210
Model: NVIDIA P3450-Porg
Board: NVIDIA P3450-PORG
DRAM: 4 GiB
MMC: Tegra SD/MMC: 0, Tegra SD/MMC: 1
Using default environment

In: serial
Out: serial
Err: serial
Net: No ethernet found.
Hit any key to stop autoboot: 0

Thanks for your help

hello jaimer2ff6,

could you please refer to Kernel Boot Time Optimization session and follow the steps in [Disable Console over UART].
thanks

@JerryChang, I tried to disable the console following the guide above but I was not able to, can you provide more detailed instructions?
What I did is modify the file p3448-0000.conf.common under the Linux_for_tegra folder that is created by the jetson_sdk manager. then I flashed the nano using the sdk manager. I am not sure this is the correct procedure.
Sorry for the basic question, but I don’t have a lot of experience doing this kind of modifications.

hello Jaime_Element,

suggest you refer to Topic 1056971 to disable the console and reduce the booting time.
thanks

Hello
I am trying to check RS232 protocol using USB-232 converter in one of USB port of jetson nano. When i short 2-3 pins of connector to perform loopback task, I am not getting anythong on serial terminal. I am using minicom for the same. When I use same connector on PC its working fine. What may be the issue??