J41, j44 Serial port not working - jetson nano

Greeting folks!

To start with, I wanted to view the uboot output coming to serial ports. Unsuccessful at that attempt, I thought I’ll dig a little deeper and first investigate if the serial ports work right by themselves…

Setup: I have a linux box running ubuntu that has a usb-serial connector connected to j44 on the jetson nano. I run minicom on the linux box and pyserial “demo” program on the jetson nano mentioned in my reference link below.

The communication parameters and wiring have been peer reviewed and can be assumed correct. Not using flow control of any sort or cts/rts looping.

In this scenario, when I type in characters on the Minicom terminal, it shows up correctly on the pyserial demo screen. Yah! But the characters sent by pyserial program are either not seen on the minicom terminal or or seen as gibberish. For reference, the python program sets up the serial port as follows
serial_port = serial.Serial(
port="/dev/ttyTHS1",
baudrate=115200,
bytesize=serial.EIGHTBITS,
parity=serial.PARITY_NONE,
stopbits=serial.STOPBITS_ONE)

This behavior make me believe that the RX part works on the jetson nano, but the tx part does not work - since nothing is seen on the minicom screen.

I have disabled nvgetty.service that hijacks /dev/ttyTHS1 on the jetson nano, tried two different USB-serial. cables and also tried using j41 ports - all to no avail. Any pointers appreciated…

References
Using j41 -https://www.jetsonhacks.com/2019/10/10/jetson-nano-uart/#:~:text=When%20the%20Jetson%20starts%20up,and%20power%20on%20the%20Jetson.
Using j44 - https://www.jetsonhacks.com/2019/04/19/jetson-nano-serial-console/

Environment
dlinano@jetson-nano: ~/UARTDemo $ cat /etc/nv_tegra_release
R32 (release), REVISION: 3.1, GCID: 18186506, BOARD: t210ref, EABI: aarch64, DATE: Tue Dec 10 06:58:34 UTC 2019

dlinano@jetson-nano : ~/UARTDemo $ cat /etc/os-release
NAME=“Ubuntu”
VERSION=“18.04.4 LTS (Bionic Beaver)”
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME=“Ubuntu 18.04.4 LTS”
VERSION_ID=“18.04”
VERSION_CODENAME=bionic
UBUNTU_CODENAME=bionic

Similar issues


hello nanujrxaq,

were you based-on a virtual machine?
may I know had you tried the approaches in post #6 from Topic 81352.
thanks