Jetson Nano USB devices no longer working after modifying xorg.conf

I was messing around with getting opencv to record .mp4 in a headless state as the mp4 would not playback if it was created without a hdmi plug connected and I came across a post that mentioned creating a virtual display in /etc/X11/org.conf file. Unfortunately after reboot I got a series of messages as such
tegradc tegradc.1: dpd enable lookup fail:-19
imx219 7-0010: imx219_boad_setup: error during i2c read probe (-121)
imx219 7-0010:board setup failed
same as above two lines but 8-0010 instead of 7-0010
cp: not writing through dangling symlink ‘etc/resolv.conf’
cgroup: cgroup2: unkown option “nsdelegate”
sqashfs: SQUASHFS error: Xattrs in filesystem, these will be ignored
sqashfs: SQUASHFS error: unable to read xatter id index table
(both sqash repeated 4x)
random crng init done
random: 7 urandom warning(s) missed due to ratelimiting
Bridge firewalling registered
it would hang at Bridge firewalling registered.
I then reflashed the sd card with a blank original image that nvidia provides for the jetson and was able to get the select your region or whatever default prompts at first boot but no usb input was being read. Luckily I had a ubuntu image I was able to load that had ssh setup and I was able to ssh into it and check the xorg.conf but with the different image it had reverted.

When I run sudo dmesg | grep usb I get
[ 0.439412] iommu: Adding device 70090000.xusb to group 2
[ 0.519267] vdd-usb-vbus: 5000 mV
[ 0.519490] vdd-usb-vbus: supplied by vdd-5v0-sys
[ 0.519853] vdd-usb-vbus2: 5000 mV
[ 0.563202] usbcore: registered new interface driver usbfs
[ 0.563259] usbcore: registered new interface driver hub
[ 0.563304] usbcore: registered new device driver usb
[ 0.629075] vdd-usb-vbus2: supplied by vdd-3v3-sys
[ 0.630926] vdd-usb-hub-en: 5000 mV
[ 0.631270] vdd-usb-hub-en: supplied by vdd-1v8-sys
[ 1.048907] tegra-xusb-padctl 7009f000.xusb_padctl: TEGRA_FUSE_SKU_CALIB_0 = 0x71a740d
[ 1.048916] tegra-xusb-padctl 7009f000.xusb_padctl: TEGRA_FUSE_USB_CALIB_EXT_0 = 0x4
[ 1.050536] tegra-xusb-padctl 7009f000.xusb_padctl: dev = phy-usb2.0, lane = usb2-0, function = xusb
[ 1.050887] tegra-xusb-padctl 7009f000.xusb_padctl: dev = phy-usb2.1, lane = usb2-1, function = xusb
[ 1.051029] tegra-xusb-padctl 7009f000.xusb_padctl: dev = phy-usb2.2, lane = usb2-2, function = xusb
[ 1.051247] tegra-xusb-padctl 7009f000.xusb_padctl: dev = phy-pcie.3, lane = pcie-0, function = pcie-x1
[ 1.051355] tegra-xusb-padctl 7009f000.xusb_padctl: dev = phy-pcie.4, lane = pcie-1, function = pcie-x4
[ 1.051462] tegra-xusb-padctl 7009f000.xusb_padctl: dev = phy-pcie.5, lane = pcie-2, function = pcie-x4
[ 1.051558] tegra-xusb-padctl 7009f000.xusb_padctl: dev = phy-pcie.6, lane = pcie-3, function = pcie-x4
[ 1.051648] tegra-xusb-padctl 7009f000.xusb_padctl: dev = phy-pcie.7, lane = pcie-4, function = pcie-x4
[ 1.051731] tegra-xusb-padctl 7009f000.xusb_padctl: dev = phy-pcie.8, lane = pcie-5, function = xusb
[ 1.051822] tegra-xusb-padctl 7009f000.xusb_padctl: dev = phy-pcie.9, lane = pcie-6, function = xusb
[ 1.159647] usbcore: registered new interface driver r8152
[ 1.159697] usbcore: registered new interface driver asix
[ 1.159760] usbcore: registered new interface driver ax88179_178a
[ 1.159798] usbcore: registered new interface driver cdc_ether
[ 1.159847] usbcore: registered new interface driver net1080
[ 1.159895] usbcore: registered new interface driver cdc_subset
[ 1.159932] usbcore: registered new interface driver zaurus
[ 1.159996] usbcore: registered new interface driver cdc_ncm
[ 1.164886] tegra-xusb 70090000.xusb: USB2 port 0 has OTG_CAP
[ 1.165499] tegra-xusb-padctl 7009f000.xusb_padctl: enabled OTG on UTMI pad 0
[ 1.166891] tegra-xusb 70090000.xusb: extcon 0: ffffffc0f966ac00 id
[ 1.169579] usbcore: registered new interface driver uas
[ 1.169643] usbcore: registered new interface driver usb-storage
[ 1.169775] usbcore: registered new interface driver usbserial
[ 1.169873] tegra-xusb 70090000.xusb: Firmware timestamp: 2020-07-31 09:33:12 UTC, Version: 50.26 release
[ 1.169937] tegra-xusb 70090000.xusb: xHCI Host Controller
[ 1.169968] tegra-xusb 70090000.xusb: new USB bus registered, assigned bus number 1
[ 1.170814] tegra-xusb 70090000.xusb: hcc params 0x0184f525 hci version 0x100 quirks 0x00050010
[ 1.170874] tegra-xusb 70090000.xusb: irq 61, io mem 0x70090000
[ 1.171250] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[ 1.171259] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 1.171264] usb usb1: Product: xHCI Host Controller
[ 1.171269] usb usb1: Manufacturer: Linux 4.9.253-tegra xhci-hcd
[ 1.171273] usb usb1: SerialNumber: 70090000.xusb
[ 1.173045] tegra-xusb 70090000.xusb: xHCI Host Controller
[ 1.173061] tegra-xusb 70090000.xusb: new USB bus registered, assigned bus number 2
[ 1.173170] usb usb2: We don’t know the algorithms for LPM for this host, disabling LPM.
[ 1.173297] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003
[ 1.173304] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 1.173309] usb usb2: Product: xHCI Host Controller
[ 1.173313] usb usb2: Manufacturer: Linux 4.9.253-tegra xhci-hcd
[ 1.173319] usb usb2: SerialNumber: 70090000.xusb
[ 1.176186] tegra-xusb-padctl 7009f000.xusb_padctl: power on UTMI pads 0
[ 1.177200] usbcore: registered new interface driver xpad
[ 1.177756] tegra-xusb 70090000.xusb: Upgrade port 0 to USB3.0
[ 1.177764] tegra-xusb 70090000.xusb: Upgrade port 1 to USB3.0
[ 1.274942] usb usb1: usb_suspend_both: status 0
[ 1.275108] usb usb2: usb_suspend_both: status 0
[ 1.368088] usbcore: registered new interface driver usbhid
[ 1.368090] usbhid: USB HID core driver
[ 1.373785] usbcore: registered new interface driver snd-usb-audio
[ 3.178675] tegra-xusb 70090000.xusb: entering ELPG
[ 3.180774] tegra-xusb 70090000.xusb: entering ELPG done
[ 8.141622] usb0: HOST MAC ea:ec:db:7b:fa:86
[ 8.141837] usb0: MAC ea:ec:db:7b:fa:87
[ 8.176254] l4tbr0: port 2(usb0) entered blocking state
[ 8.176259] l4tbr0: port 2(usb0) entered disabled state
[ 8.176827] device usb0 entered promiscuous mode
[ 8.184993] IPv6: ADDRCONF(NETDEV_UP): usb0: link is not ready
[ 8.684233] IPv6: ADDRCONF(NETDEV_CHANGE): usb0: link becomes ready
[ 14.372412] l4tbr0: port 2(usb0) entered blocking state
[ 14.372417] l4tbr0: port 2(usb0) entered forwarding state
[ 31.858944] vdd-usb-vbus: disabling
[ 31.858947] vdd-usb-vbus2: disabling
[ 31.859089] vdd-usb-hub-en: disabling

I’m not sure what else I can do to get the USB ports to work again. I have tried powering from a 5v 2a barrel, and powering from microusb through a usb outlet and computer but none of those give me power to the usb ports. Also tried the forcing recovery mode to no avail.
Not sure exact model but it is a jetson nano (tx1 i think) has two csi inputs 4 usb 3.0 1 hdmi 1 dp 1 eth 1 micro 1 5v barrel.

Any advice would be greatly appreciated as I can’t run a fresh image on it anymore if I cant get past the selecting language/region etc.

Does it work if you reset xorg.conf to the default one? For running a sample like this:
Displaying to the screen with OpenCV and GStreamer - #9 by DaneLLL

You should not need to touch X11 setting although no TV is connected in HDMI out. We would suggest reset to default and check if the USB devices can be detected.

When I loaded up another ubuntu image on the jetson and checked the xorg.conf the lines I had changed were no longer there and last time I ran this image the usb ports were working.
I cant find the original post but It was from the developer forms and had very similar steps to this one How do I set a permanent display resolution?
[Honey_Patouceul] first comment

This won’t answer, but you might find some of this useful…

Xorg does not drive any device directly. Instead, it loads drivers dynamically, or an interface to the driver, similar to a library. NVIDIA’s GPU driver for example loads into Xorg, and must be binary compatible with the particular Xorg server which the driver plugs into. Often people will attempt to upgrade the Xorg server, and then the ABI changes, and the NVIDIA driver will fail to load. That’s what people notice, because without the graphics, you can’t see what else is broken.

There is also an xinput driver for keyboard and mouse. This too must be binary compatible. If and only if we are talking about the GUI from Xorg, then mouse and keyboard would appear to fail. However, this is not USB failing, it is the driver loading into the Xorg ABI that fails. I suspect USB was working, and that something about your modification changed driver loading.

What confuses me is that you said you were working in headless mode. Xorg should have nothing to do with most headless modes unless you are forwarding X events to another server (it could be a virtual or remote server). The basic framebuffer console does not normally care about Xorg (nor drivers loaded into Xorg).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.